powered by Jive Software

Remove Server/Resource from Display

I recently installed an Openfire Server (latest version) on the reccomendation from a Friend. Im using a MySQL Backend, with the same for Authentication (No LDAP).

I’ve managed to get into the server fine, and I’ve gotten it pretty much set up. When logging in as a User via Pidgin (Jabber/XMPP Client), I’ve been noticing that whenever I send a message it appears like:

(7:03:03 PM) ayka@im.pvpgames.com/2711b4cf: Hi back!

with the Domain, and the Resource ID. I didn’t set a Resource when connecting to the server.

I’d like it just to display as “Ayka”, the person who recommended it to me had his server set up so it did not display the Domain/Resource, but he can’t seem to remember how he did it.

Any help would be appreciated!

Thanks

another thing I’ve just noticed, Its converting everyone to Lowercase names, when receiving a message. Even if our accounts have uppercase characters. Possibly related?

First of all, you are speaking about how a client is showing your name in the chat window. This is not configured via server and there is probably some setting in Pidgin to set this to whatever you want.

Another case would be, if you want others to see your messages coming from “Ayka” and not from ayka@im.pvpgames.com/2711b4cf. You can go to Admin Console and edit your user’s properties and change Name field to Ayka. Then you can put your user into some group and turn on sharing of that group to others. Then others will see that group and they will see your user as Ayka in this group. This is not the case if they have added your user to their rosters manually. You can’t control how your user is displayed in their clients then.

Usernames are not case sensitive in xmpp/jabber, so server is making them all lowercase, because it is needed by standards. I can’t explain it better, but that’s how it is.