powered by Jive Software

Restarting server makes me Openfire setup every time!

Dear Team,

I have one problem with my Openfire server, I install Openfire on CentOS 6.7. And after installation I don’t have now problem but after few days maybe after reboot I am not sure I try to login into console but I see installation page, So I install server again and when I try to go into login page I am redirected again to begin of installation setup page after reboot the server, And this situation is all the time I try finish installation and I redirected to begin,

I don`t have no idea what I can do. Some required info are given below:

==========
OS: CentOS 6.7

Version: Openfire 4.0.2
Server Directory: /opt/openfire
Server Name: localhost.localdomain

Java Version: 1.8.0_74 Oracle Corporation – Java HotSpot™ Server VM
Appserver: jetty/9.2.z-SNAPSHOT
Host Name: localhost.localdomain

FYI…Some how the /opt/openfire/conf/openfire.xml file is empty right now.

Owner/Group is **daemon/daemon **and permission is drwxrwxr— for Openfire.

Thank you for your help in advance !

Regards,
Tarak Nath

Usually this is a permission problem. Make sure the user running Openfire has full access to the /opt/openfire folder (recursively). Are you sure daemon/daemon really runs the Openfire when server boots and not some other user?

Thank you very much WROOT !!

Yes, permission already given. Also confirmed that daemon/daemon really runs the Openfire when server reboot.

I would like to inform you that some how the /opt/openfire/conf/openfire.xml file is empty right now. I think this files should not be blank.

Please @wroot help me for best working solution for my critical issue.

Regards,

Tarak Nath

It shouldn’t be empty. Try reinstalling Openfire.

1 Like

Hello @wroot ,

As of now problem is resolved after reinstall.

I will come back if the issue is reoccur in future. Thank you very much !

Have a nice day !

Regards,

Tarak Nath

Ok. Just don’t mention my nickname in the reply. I already get a notification about a new reply. But i also get additional notification when my nickname is mentioned.

Hi WROOT,

Okay ! This will be not repeated !

Have a nice day ! Good Bye !

Regards,

Tarak Nath

I had a similar problem in windows 2012 server and I solved it giving modify rights for users group to the files in folder conf

1 Like

Thank you Ivan for sharing with us !

I also faced the same issue. As per your suggestion, I modified ownership and group name to the files of conf folder. It is working fine. Thanks a lot.

I am having the same problem. I am using Openfire 4.2.3 version. my folder owner in jive/jive . There is no user call daemon/daemon . I have installed it in rhel 7 from tar file.
@wroot Please guide me why It is happeing?

This issue will come in picture because of your conf folder doen’t have write permission and after setting up openfire will modify openfire.xml and write that set up is done but because of your application don’t have enough permission so it couldn’t do it and you need to setup each time you restart your server.

For Resolution you have to give full permission to openfire dir and second is don’t modify anything in that file if you don’t know how to modify.

Other work around is try to override false with true in conf/openfire.xml after configuration has been done.