powered by Jive Software

Roster disappearing

Hi,

you don’'t have to care about a connection timeout if you are using the internal database as there is no TCP connection to it which could time out.

Do you get only the users or also some groups from LDAP?

A similar thread is http://www.igniterealtime.org/forum/thread.jspa?messageID=147353 - currently with no response so I wonder if it helps to change the roster cache in any way.

LG

I have connectionTimeout set to .01 and still seeing this error. Running Openfire 3.3.1 on RHEL 4 U4.

I would try setting ?autoReconnect=true at the end of your JDBC connection string in the openfire.xml.

Still having the problem, but I noticed this… do I still need to make an adjustment?

Cache Name Max Size Current Size Percent Used Effectiveness*

Roster 0.50 MB 0.45 MB 89.1% 89.4%

What other options do I have?

In order for me to get a list up, sometimes I have to logon and off several times to get the list.

Im using AD to pull groups, and AD for vCard, AD for auth, this problem seem to have gotten worse with newer versions of spark and wildfire, but I cant pin point to the exact version combo. Also should be mentioned that Im using the Global Catalog, over SSL in a DMZ. So could it be a timeout issue? how can I tell? is there a configuration point I can adjust?

Your effectiveness % shows it’‘s okay, but I increased the cache size of my roster to 2MB. I’‘ve been having the same experience and here’‘s the adjustments I’'ve made so far:

Name: cache.username2roster.size

Value: 2097152

Name: cache.userCache.size

Value: 2097152

Name: cache.vcardCache.size

Value: 2097152

Things to consider: if the other user deletes you they will be removed from your roster as well. If the name is not showing up in the right group, but instead is showing as the full JID (user@jabber.server.com) in your offline group, remove them and then readd them. These steps have cleared up the majority of our issues so far. Still tracking to make sure they are gone. Been a few days so far.

I tried setting ?autoReconnect=true at the end of your JDBC connection string in the openfire.xml. I also have connectionTimeout set to .01

I am still getting the Timeout errors and still having problems with the Roster disappearing. Anything else I can do to fix this? Running Openfire 3.3.1

I have adjusted my cache, upgraded spark, all sorts of things, and the issue is still here. Question as any one had these issues using a client other then spark? Could the problem reside inside spark? It seems odd that all of us here in this thread have a similar issue but dissimilar installs and setups.

Have you tried it with a different client to see if you can reproduce the issue?

Yeah we’'re using Spark and Pidgin and they both having disappearing rosters. (however this was before the connetionTimeout value to 0.01 was implemented)

Will let you know if there’'s any problems.