I’'m not really sure if this is the right place and way to report “bugs” like this one, so sorry if I did anything wrong or this “bug” was already reported.

I’'ll be alway thankfull for corrections.

The RosterPacket.ItemStatus.UNSUBCRIPTION_PENDING should probably be called “RosterPacket.ItemStatus.UNSUBSCRIPTION_PENDING”


I just created SMACK-175 to get this fixed.


but why says the description “Currently it’'s just defined and nowhere used”? ^^

if you want to know if an RosterEntry has answered your Subscriptionrequest you have to check if getStatus() equals to RosterPacket.ItemStatus.UNSUBCRIPTION_PENDING or is there an better way to check this?

Of course it doesn’‘t matter if there is an ‘‘s’’ or not because the End-user doesn’'t get in direct contact with this, it just attracted my attention when i added “UN” to SUBSCRIPTION and Eclipse told me that this does not exist