Run Openfire as a service

I installed openfire on a window XP box. Everything works great when I start openfire manually after login.

I stopped and quit openfire and ran from the command prompt “openfire-service /install” and “openfire-service /start” but no client connections are made. The service is running according to Computer Management. I rebooted the computer and still no client connections are made.

I am using the client Pandion.

Is there another setting to be done on either the client side or server side?

PS several months ago I set up openfire on a windows 2003 server and started it as a service using the same commands and it worked great.

I know this message is stale (very stale) but I just ran into the same issue, and it took half an hour for me to figure out what was wrong. Just to save some future person from experiencing this, I think I better document the ‘fix’.

Windows XP (sp2+) has the windows firewall running by default. Openfire adds it’s exe to the exception list by default on install so that it may open external listening ports, however the SERVICE exe is not added.

You can quickly go into control panel, windows firewall, exceptions, add program. Add the openfire-service.exe, and make sure it’s scope is set to Any Computer.


The difference could be as simple as XP has a built in firewall. You would need to allow all the ports in the firewall to allow openfire to work. It may be easier to allow the application instead of ports, or to simply disable the firewall on XP (the last is very risky).