powered by Jive Software

Running OpenFire on MS SQL (2008)

Hi,

I’m trying to run Open Fire on MS SQL 2008, but I’m only beginning to experimentate with this software, so I have no idea hou to maky it work. OpenFire Database setup always says “A connection to the database could not be made. View the error message by opening the “\logs\error.log” log file, then go back to fix the problem.” I’ve created apropriet database and I’m using db–owners name and password to acces it.

But if I understood it right, I also need to instal JDBC (FreeTDS) directly to the SQL server, Well, I have no idea how to make it work. I would be really glad, if someone could make a step by step manual, how to make OF functional…
error.log (9802 Bytes)

You shouldn’t have to do anything on the SQL server machine. Looking at your logs it seems to be that the account isn’t setup correctly. java.sql.SQLException: Login failed for user ‘OpenFire’. I would double check all your remote login settings and ensure that you have the right password.

Cheers,

Nate

So, I don’t need to run any server side JDBC application? Well anyway, I thought that I did something wrong (or actually forgot to do something) in account configuration… So far I have very limited experiences with MS SQL security setup.

EDIT: Well, I followed this http://www.technology.net.au/documents/wildfire/ step-by-step manual (well, as far as I could, becouse there are a little diferences in SQL server 05/08, but only cosmetical) and created tables via SQL querry. But I always got stuck in acces authentification as in my first post. So, there has to be some other non-standard glitch that I am missing…
error.log (6394 Bytes)

Are you trying to connect to SQL with windows auth? I had the same SQL problem connecting until I went with SQL auth.

Hi, have the same problem with SQL Express 2008, SQL authentication doesn’t help. Also tried to set instace to SQLEXPRESS2008 in Database url: jdbc:jtds:sqlserver://Vovan-PC/Openfire;appName=jive; instance=SQLEXPRESS2008. Still doesn’t work.

Any ideas?

You need to be running the SQL server in SQL authentication mode. Create a new SQL user for the openfire database, create a new SQL database for openfire. Then during the config of openfire use this new user and database in the settings. Openfire config will not automatically create the database. It will merely place the tables.

Why not start your own thread instead of hijacking somebody else’s.

I had the same issue installing in Sql Server 2008 R2 the way I made work is set the db user role for openfire as dbowner and the instalation was succesufull hope this will help someone thank you

I am guessing you didn’t run the create table scripts - these instructions worked for me

http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/database .html