S2s problem with jabber.org and gmail.com

I am having problem to establish s2s connection to either jabber.org or gmail.com. I have already enabled the s2s service and allowed any remote server to connect to my server inside the Wildfire server configuration. Also, I’‘ve registered the SRV records for xmpp-server.tcp.creaf.com, xmpp-client.tcp.creaf.com and jabber.tcp.creaf.com for my company’‘s domain creaf.com. The ports 5222, 5223 and 5269 are already opened at the firewall end and I’'ve tested that indeed I can connect to my Wildfire server from the Internet using a Jabber client and also telnetting to the 3 ports that is opened.

However, when I tried to add a jabber.org or gmail.com contact, an error will be prompted after 1-2 mins. The debug log for Wildfire is as follows :

2006.07.21 16:04:32 OS - Trying to connect to gmail.com:5269(DNS lookup: xmpp-server3.l.google.com:5269)

2006.07.21 16:04:33 OS - Plain connection to gmail.com:5269 successful

2006.07.21 16:04:33 OS - Going to try connecting using server dialback

2006.07.21 16:04:33 OS - Trying to connect to gmail.com:5269(DNS lookup: xmpp-server3.l.google.com:5269)

2006.07.21 16:04:33 OS - Connection to gmail.com:5269 successful

2006.07.21 16:04:34 OS - Sent dialback key to host: gmail.com id: 46D1F70DDD420BCD from domain: creaf.com

2006.07.21 16:04:54 OS - Time out waiting for answer in validation from: gmail.com id: 46D1F70DDD420BCD for domain: creaf.com

2006.07.21 16:04:54 Error sending packet to remote server:

java.lang.Exception: Failed to create connection to remote server

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:143)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:40)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:95)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

2006.07.21 16:05:15 Finishing Outgoing Server Reader. No session to close.

java.net.SocketException: Socket closed

at java.net.SocketInputStream.socketRead0(Native Method)

at java.net.SocketInputStream.read(Unknown Source)

at org.jivesoftware.wildfire.net.ServerTrafficCounter$InputStreamWrapper.read(Serv erTrafficCounter.java:183)

at sun.nio.cs.StreamDecoder$CharsetSD.readBytes(Unknown Source)

at sun.nio.cs.StreamDecoder$CharsetSD.implRead(Unknown Source)

at sun.nio.cs.StreamDecoder.read(Unknown Source)

at java.io.InputStreamReader.read(Unknown Source)

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2992)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3046)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:75)

at org.xmlpull.mxp1.MXParser.nextToken(MXParser.java:1100)

at org.dom4j.io.XMPPPacketReader.parseDocument(XMPPPacketReader.java:303)

at org.jivesoftware.wildfire.server.OutgoingServerSocketReader$1.run(OutgoingServe rSocketReader.java:91)

I’'ve also tried to add my Wildfire account from my jabber.org account but I do not get any authorization prompt/request at all.

I am running out of ideas why the connection just refuses to work. Can anyone can point me in the correct direction to resolve this? Thanks.


Found the problem. I’'ve register the wrong tcp port inside the DNS and therefore connections cannot be made.