powered by Jive Software

S2s problems with 2.2.0

Is anyone else experiencing tons of s2s issues with JM 2.2.0 final? Everything was going fine today until I lost the connection to the server (some NAT issues on my end). When I fixed everything and reconnected, I could talk to people connected to the server and to my transports (barely), but nothing could get outside of JM. Any time I attempted to join a groupchat, do disco, etc., on other servers, it wouldn’‘t even attempt to initiate the connection as best I can tell from looking at the logs. I tried with JBother (which uses Smack) and Psi, but had the same problem with both. I’‘ve also tried restarting the server and I’‘m having the same problems. So any ideas? Anything I should look for? I’'d really like to get everything rolling again. Thanks!

Let me also mention I’‘ve watched (via my XML logs on my client) JM not respond to private storage requests, roster requests, etc. The client sends the request and JM doesn’‘t seem to respond. I’‘m pulling my hair out trying to figure out what’'s wrong.

Oh, and this seems to be an error that keeps popping up in the error.log:

2005.08.03 19:58:17 org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:145) Connection closed before session established

Socket[addr=/127.0.0.1,port=36792,localport=5269]

2005.08.03 19:59:13 org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:145) Connection closed before session established

Socket[addr=/66.240.239.24,port=40427,localport=5269]

2005.08.03 20:00:13 org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:145) Connection closed before session established

Socket[addr=/66.240.239.24,port=40429,localport=5269]

2005.08.03 20:01:13 org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:145) Connection closed before session established

Socket[addr=/66.240.239.24,port=40433,localport=5269]

Message was edited by: MysticOne

mysticone

Okay, I think I have figured something out. Apparently it has to do with the buddies in my roster that are from transports (PyAIM-t, PyICQ-t, PyMSN-t). I created a new user on the server and logged in and I have no s2s, disco, etc., problems. I’‘ve completely disabled the transports but my main user still can’‘t login. Perhaps there’'s a problem when it tries to get the presence information for all these people? Sorry to keep replying to my own messages, but not sure how else to keep annotating this stuff without re-editing the original message each time.

I’‘m experiencing something,b ut unsure what it is. I’‘ve already got a thread going (S2S and Jive Messenger RC1). I ahve since upgraded to 2.2.0 final, but it doesn’'t seem to be fixing anything.

I’‘m using eXodus 0.9.1.0 as a client, but for some reason my rosters aren’‘t appearing on either server. Adding people doesn’'t seem to work either.

Are you able to do service discovery, join conferences, etc?

Hey Daniel,

Could you turn on the debug log and let us know what you see in the debug.log file? Is there error in the error.log file? How are your servers configured (eg. hostnames)? Could you post the XML of a packet that you are sending and is not getting through?

Thanks,

– Gato

Hi,

i got a similar problem: with a newly registered account (with only ~3 contacts) i have no problem with disco,presence changes, etc. but with my main account with a roster which also has more & older entries (and entries from transports), it seams that e.g. presence packets get queued, and processed later (like changing presence to away, and i still be marked as online for >30 mins … for contacts on other servers, for contacts on the same server and even for the administration console… ) … but i guess the reason for my problem is, that i’'ve got old roster entries which are on inactive servers since my whole server log is full of:

2005.08.06 02:30:58 Error connecting to the remote server: jabber.at(DNS lookup: jabber.at)

java.net.UnknownHostException: jabber.at

2005.08.06 02:30:57 Error connecting to the remote server: charente.de(DNS lookup: s2s.nbg2.eniac.de)

java.net.UnknownHostException: s2s.nbg2.eniac.de

… etc …

(btw. is it possible, that if the server can’‘t resolve jabber.at it tries to resolve ‘‘at’’ ? since i’‘ve also got error messages pointing out it couldn’'t resolve at)

cu

Herbert Poul

I finally got fed up with it, cleared my whole roster, and started over. I actually had to delete all the records from my MySQL database for my user to get it to work.

The only errors I saw were the ones I posted earlier in this thread. That is one of the reasons I was having such a difficult time diagnosing it, because there weren’'t any errors to let me know what was going wrong.

As for the XML, here’'s a little excerpt of some of the ones I had problems with:

Fetching bookmarks for MUCs:

Umm, that’‘s all I can think of at the moment. The hostname for my server is foxybanana.com. I also have AIM, MSN, and ICQ transports on aim.foxybanana.com, msn.foxybanana.com, and icq.foxybanana.com. They’'re all running the python transports (PyAIM-t, PyMSN-t, and PyICQ-t).

Hi mysticone =D

I’‘m having this very same problem. I can not talk with the outside world it seems. I see a lot of attempts to deal with msn.jabber.vorpalcloud.org and friends, and some supposed connections with some outside servers, but when I log in, I can’'t talk to anyone in the outside world. Odd. =( Any ideas?

Was this not a problem in previous versions?

Anyway, yeah, at the moment I simply can’‘t switch to jive it seems because this just does not want to behave. =( (I’'m trying to switch from ejabberd)

I tried to use the latest nightly build but apparantly did something wrong because it had no intentions of getting beyond the initial setup phase. =)

Do you see it actually make connections to any other servers in the server session list (on the sessions tab)? Or, does every connection fail? Be sure to test with some well-known servers such as jivesoftware.com or jabber.org.

Regards,

Matt

Ohh – also, is your server name something that’‘s actually DNS-resolvable by other servers? If you paste in your full server name I’'d be happy to try a DNS lookup on my end.

-Matt

I do see servers show up in the sessions tab, such as jabber.org and a lot of various others that I talk to regularly. So things “appear” to be ok from the web admin but then when I connect… well first of all the bulk of my contacts are on other servers… and none of them are shown as online. Also, I tried to connect to a conference room on conference.jabber.org and it never connected. The server is resolvable from outside sources and when I run the very same server via jabberd2, jabberd1, or ejabberd, everything works just fine. (In fact I switched back to ejabberd for the time being until I can get this resolved) I’‘m not sure what’'s going on. I do see a lot of log messages that are interesting:

In error.log, loooot of instances of:

2005.08.13 23:54:25 org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:145) Connection closed before session established Socket[addr=/10.0.0.1,port=45127,localport=5269]

I also see:

2005.08.13 23:47:53 org.jivesoftware.messenger.server.ServerDialback.createOutgoingSession(ServerDia lback.java:194) Error creating outgoing session to remote server: icq.jabber.vorpalcloud.org(DNS lookup: icq.jabber.vorpalcloud.org)

(icq.jabber.vorpalcloud.org is obviously one of my components, PyICQ, which is not running at this very moment) But icq.jabber.vorpalcloud.org resolves on my box. It does not resolve externally, but it’'s not supposed to need to.

I have a lot of java ‘‘stack traces’’ of sorts here and there.

In fact, the more I look at it, the more “DNS” issues I see with it trying to resolve icq.jabber.vorpalcloud.org, aim.jabber.vorpalcloud.org, and friends.

host icq.jabber.vorpalcloud.org

icq.jabber.vorpalcloud.org has address 10.0.0.1

I don’‘t see why it couldn’‘t look that up. I don’'t see anything sensitive (or at least that I care about) in the logs, so I have made them all available here:

http://www.vorpalcloud.org/~daniel/jivelogs/

I cant add buddys in intranet for outgoin sessions[/b]

PLEASE HELP!! :(/b

at org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:111)

at java.lang.Thread.run(Unknown Source)

2005.08.17 10:56:13 [org.jivesoftware.messenger.server.ServerDialback.createOutgoingSession(ServerD ialback.java:194)

] Error creating outgoing session to remote server: labtronica01(DNS lookup: labtronica01)

java.net.ConnectException: Connection refused: connect

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(Unknown Source)

at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.SocksSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at java.net.Socket.(Unknown Source)

at javax.net.DefaultSocketFactory.createSocket(Unknown Source)

at org.jivesoftware.messenger.server.ServerDialback.createOutgoingSession(ServerDi alback.java:130)

at org.jivesoftware.messenger.server.OutgoingServerSession.authenticateDomain(Outg oingServerSession.java:113)

at org.jivesoftware.messenger.spi.RoutingTableImpl.getRoute(RoutingTableImpl.java: 92)

at org.jivesoftware.messenger.spi.RoutingTableImpl.getBestRoute(RoutingTableImpl.j ava:224)

at org.jivesoftware.messenger.MessageRouter.route(MessageRouter.java:80)

at org.jivesoftware.messenger.PacketRouter.route(PacketRouter.java:69)

at org.jivesoftware.messenger.net.SocketReader.processMessage(SocketReader.java:34 3)

at org.jivesoftware.messenger.net.ClientSocketReader.processMessage(ClientSocketRe ader.java:55)

at org.jivesoftware.messenger.net.SocketReader.readStream(SocketReader.java:182)

at org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:111)

at java.lang.Thread.run(Unknown Source)