Secure admin console port disabled after upgrade from 3.1.1 to 3.2.0

I tried this on two different hosts just to be sure. I’‘m ultra paranoid about security, so I require SSL all the way around. After upgrading to 3.2.0, wildfire isn’‘t even listening on port 9091 anymore. I’‘ve been running wildfire since 2.6.2, and it’'s always worked well.

All other SSL/TLS functions are working fine though. Can anyone else confirm this as a bug?

You must log in to admin console (plain) and recreate certs for your server. After that secure admin console will be available as usual.

Question is why 3.2.0 isn’'t shipped with default certs?

this worked!!!

Message was edited by: opie6373

Wildfire 3.2.0 is validating that there are valid certificates for the hosted domain. That means that if your XMPP domain is then Wildfire searches for an RSA certificate that secures the If none was found then the port 9091 is not started and only unsecured connections are allowes. For Wildfire 3.2.1, to be our this week, we changed that behavior to accept any RSA certificate and print a warning in case the cert is not securing the hosted domain. Anyway, an RSA certificate is still required for the webserver to be listening on port 9091.

Wildfire 3.2.0 will create a DSA and RSA certificates once the setup process is completed. The 2 newly created certificates will be securing the specified domain during the setup. Moreover, from the certificate management page in the admin console you can also create new certificates.

When updating Wildfire existing certificates are not replaced. Prior to Wildfire 3.2.0 Wildfire was providing 2 out of the box certificates with a dummy domain. That is the reason why updating an old Wildfire to Wildfire 3.2.0 is “breaking” the port 9091. An easy solution is to recreate the certificates so that they are valid for the hosted domain. Anyway, Wildfire 3.2.1 is less strict in that respect.


– Gato

do you mean 3.1? i wasn’'t aware of a 3.2.1

Wildfire 3.2.1 will be released this week. The new release will include many important bug fixes.


– Gato

stop fixing things. 3.1.1 was working great and b/c i’'m obsessive about installing the latest version or updates, i had to install 3.2 and things stopped working!!!


i’'m kidding by the way…

Unfortunately, for Wildfire 3.2.0 we had to make some changes to the API and that was the reason why many plugins stopped working. For Wildfire 3.2.1 we changed the server to be more error-tolerant with “faulty” plugins.


– Gato