Sending file

I have been trying to send the file from user 1 to user2 but somehow it is not working and there is no error. I am using the “” as the jabber server and running the spark client to connect it. However I can send text message using spark client but send file is not working.

Any help ?


Try with the latest Spark SVN version

Login is failing with the latest spark version, however 2.5.8 works fine except file upload. It seems that the 2.6.0 is not working.

Following is the log message when I started the debug mode.

<stream:stream to=“” xmlns=“jabber:client” xmlns:stream=“” version=“1.0”>

Y2hhcnNldD11dGYtOCx1c2VybmFtZT0idXNlcj FcXDQwdWJ1bnR1MTA0LnRleGl0eS5jb21cXDJmIixyZWFsbT0idWJ1bnR1MTA0LnRleGl0eS5jb20iLG 5vbmNlPSI2YWRmZTI3ZiIsbmM9MDAwMDAwMDEsY25vbmNlPSI2MjNod09pcFJuL2NTNjNMVk5RRm1SdV V1aXh1WlJ3eEExbHR1cXZNIixkaWdlc3QtdXJpPSJ4bXBwL3VidW50dTEwNC50ZXhpdHkuY29tIixtYX hidWY9NjU1MzYscmVzcG9uc2U9NDdlN2E1MWIxNGQ4NzEwZjE2YTIyMTAxZjRkZWViMzAscW9wPWF1dG gsYXV0aHppZD0idXNlcjFcXDQwdWJ1bnR1MTA0LnRleGl0eS5jb21cXDJmIg==

user1\\2f</qu ery>


<stream:stream to=“” xmlns=“jabber:client” xmlns:stream=“” version=“1.0”>

Please note that I am using user name like : but somehow it is not getting trasported to the server

Log from psyc server:

010.11.23 16:42:50 psyclpc ready for users.
»»» Root entity ready.
not legal_name: “user1\” has ill char at 25 (46).
2010.11.23 16:45:01 Bad arg 1 to call_other(): got ‘number’, expected ‘string/array/object’.
2010.11.23 16:45:01 program: net/jabber/server.c, object: net/jabber/server#12 line 423
’ feed’ in ’ net/jabber/common.c’ (‘net/jabber/server#12’) line 109
’ xmlparse’ in ‘net/jabber/common.c (/net/xml/parse.c)’ (‘net/jabber/server#12’) line 160
’ jabberMsg’ in ’ net/jabber/server.c’ (‘net/jabber/server#12’) line 423
EXCEPTION in net/jabber/server.c:423 (net/jabber/server#12):
Bad arg 1 to call_other(): got ‘number’, expected ‘string/array/object’.
2010.11.23 16:45:01 Error in input_to().

So, in Spark you enter user1 in the username field and in the server field? Have you tried to put server’s IP instead?

Thanks for quick reply, I also tried providing the IP address instead of

the name but it didnt worked out.

25 char in the username seems to be ‘n’, or maybe it’s a dot before com which is error referring to. I don’t know anything about psyced server. Is there any public server (or yours?) that i can try to login, creat an account? Also, is it only Spark 2.6.0 that you can’t login with? What about other clients like Pidgin, Psi, etc.

The username I am using through Spark client but in the debug console of Spark as well as on psyc server log I am seeing the “user1\” instead of the one I sent.

I can login using the gajim, psi and pigin. The login is also working fine with Spark 2.5.8. but not working with Spark 2.6.0.

You can download the psyc server from “” if you want to try out.

Thank you for your help.


Are you putting into Username field on the login screen of Spark? @ is not allowed in the usernames, so Spark is probably trying to escape it with \40 (should be only 1 slash). Though i was able to login with test@test user on Openfire server with the latest Spark version. I don’t have time to test that psyced server.

What would be the syntax for username.


You can read here about the escaping of disallowed chars in usernames.