powered by Jive Software

Server to Server behind strict firewalls (proxy) with 3.0.1

Hello (again ),

I am missing a functionality with my installation (3.0.1).

I had no need of it until now, so I didn’'t realize I was missing it. I want my jabber server to be able to discuss with other server, in order to add external JID to my roaster.

Until now, we were our own IM provider thanks to wildfire, only for internal need.

Of course, when it does not work, people want bug fixes.

Of course, when it does work, people want more functionalities

I check my admin console, the server to server option is Activated, and set to the default port which is 5269.

I opened this port on my firewall (iptables scripts, the same I did it for other ports needed by Wildfire).

Nevertheless, the server is behind a non transparent proxy !

For example, I had to set the variables update.proxy.host and update.proxy.port in order to be alerted of new updates.

For my server to connect to other servers, I think I will need to set up the variables:

xmpp.proxy.enabled

xmpp.proxy.externalip

xmpp.proxy.port

xmpp.proxy.service

WHich are all marked as “TODO” at http://wiki.igniterealtime.org/display/WILDFIRE/Wildfire+Properties.

Can you confirm that I could not set up server2server connections for the time being ? I feel like I am searching for something that is not possible at the present time … So let me save time please if ti is the case !

Thanks in advance for any clue,

Regards,

cgravier.

Hi,

these properties are used by the File Transfer Proxy. So I guess that they work already but not for server-2-server connections. If they would work you would enable only outgoing s2s connections, incoming s2s connections are not possible.

LG