powered by Jive Software

Server to server connection

due to my limited knowledge in configuration of hardware, i had problem in understanding on how to allow 2 servers to communicate with each other based on the article that was posted in http://wiki.igniterealtime.org/display/WILDFIRE/Server+to+Server+HowTo.

for my environment, i am simulating with 2 laptops with wildfire installed in each of them.

the laptop is able to ping to one another successfully.

so far i had tested using the sparks program installed in laptop A to login as a user of server B

to the wildfire that resides in laptop B.

and it succeed.

however, how do i go about letting user A from server A to add user Z from server B?

what are the steps that i need to carry out to check if server A is communicating with server B?

do i use telnet? if so, how i do it and what response shld i get?

i had tried telnet (in cmd window, type

but it always return something like <stream.

is it rite to receive this?

as for the article found in the above url,

it says ''The server name of the openfire (Server/Server Manager/Server Settings) has to be a name, that can be resolved by DNS (e.g. homebase.dyndns.org)". what does this mean? can i just register the server name to be the same as my machine name?

sorry for chunking all qns together.

julenisse
gateway.jar (0 Bytes)
gateway.jar (0 Bytes)
gateway.jar (0 Bytes)
gateway.jar (0 Bytes)
gateway.jar (0 Bytes)

The server name of the openfire (Server/Server Manager/Server Settings) has to be a name, that can be resolved by DNS (e.g. homebase.dyndns.org)

It means that you will need a domainname that resolves to servers IP for all users who want to use your server. This domainname should be the same as you gave openfire while setup.

For testing it should be enough to take simply your IP-Address as domainname. Your JabberID would be user@192.168.0.42 for example.

can i just register the server name to be the same as my machine name?

No, a machine can have multiple domainnames.

Coolcat

For testing it should be enough to take simply your IP-Address as domainname. Your JabberID would be user@192.168.0.42 for example.

i need your help to tell me how to go about the testing which you mentioned. i am “technically handicap”.

so far i had tested that i am able to use the Actions->Start Chat menu to add a user based on user@192.168.0.42 (which resides in server B). see http://www.igniterealtime.org/forum/thread.jspa?messageID=122861&#122861

however, what should i do to allow the Search menu to be able to search across servers? i cant find users from server B.

Message was edited by: julenisse

however, what should i do to allow the Search menu to be able to search across servers? i cant find users from server B.

There is no Usersearch which allows to search over all Jabber-Accounts in the world. So it is not possible with the default Search-Plugin. The Search-Plugin from Server A does only search the database of server A. But you can use the plugin from Server B:

Go into service discovery from your A-Account, enter address of search-plugin from Server B (e.g search.192.168.0.42) into the address field. In this way you will be able to search for users from the other server, but not from your own.

(I’'am a Psi user, never used Spark…)

Coolcat

Go into service discovery from your A-Account, enter address of search-plugin from Server B (e.g search.192.168.0.42) into the address field. In this way you will be able to search for users from the other server, but not from your own.

tried that in sparks but it always prompt an error msg ''unable to contact search service".

is there anything i need to do to the server side?

because in the admin console->server settings->search properties, under service name section, i cant seem to be able to change it to search.[Server B IP address] .

do i need to create the 2 server in the same domain?

if so, how do i go about doing it?

tried to change the xmpp.domain to the same for the 2 server but with different server name but whenever there is a restart of server, the name of the xmpp.domain would revert to be of the same name as the server.

ok. i had managed to resolved it.

here is what i had done to allow user A from server A to search for user B from server B.


this is based on assumption that you are able to chat with user B through the Action->start a chat menu.

(see prev thread)

in the machine of Server A,

  1. go to C:\windows\system32\drivers\etc, look for the file hosts and open it with an editor.

  2. in the file, you will see the (127.0.0.1 localhost]) as your first entry.

add the IP address (eg. 192.168.0.10]) of server B, press tab, add (search.<server B name>) .

  1. login to the sparks IM, under the search box located at the bottom of the screen, press the enter key to open the search window.

  2. click the Add Service button and when prompted for the name of search service, type (search.<server B name>), click ok.

  3. you should be able to see the newly type service in the drop-down menu.

  4. in the search box, type the name of the person (in this case, user B) who resides in server B and click the search button. you should be able to see the result reflected.

do the same for Server B.

hope this help.

Message was edited by: julenisse

  1. go to C:\windows\system32\drivers\etc, look for the file hosts and open it with an editor. (…)

This should not be necessary.

because in the admin console->server settings->search properties, under service name section, i cant seem to be able to change it to search.Server B IP address .

The search-Service should be called “search”, the default setting. The server name will added automatically.

What exactly are you trying to test actually?

Coolcat

Coolcat wrote:

  1. go to C:\windows\system32\drivers\etc, look for the file hosts and open it with an editor. (…)

This should not be necessary.

had read in some previously post that i need to do this in order to allow the server to route info to the second server (just like it routes packets locally).

because in the admin console->server settings->search properties, under service name section, i cant seem to be able to change it to search.Server B IP address .

The search-Service should be called “search”, the default setting. The server name will added automatically.

somehow, it doesnt seem to allow me to change. it might be because i had set them to be not under one domain but 2.

What exactly are you trying to test actually?

was trying to test what configurations are needed for 1 server to 1 domain setup environment and 1 server to many window domain environment. so far, i had managed to get the former but still trying to figure out how i should configure for the latter.

maybe you can strike some light on 1 server to many window domains?

any help is appreciated.

I’m currently having the same problem where I am trying to search from server 1/domain 1 and see the users on server 2/domain 2.

Tech support hasn’t been able to help…have been looking for an answer for over a month and haven’t found anything…

A simple way for you information:

Server A:

hostname:ima

IP:192.168.1.x (or internet ip)

Server B:

hostname:imb

IP:192.168.1.xx (or internet ip)

First :

You must enabled S2S’s Service on Server A and Server B;

“telnet 192.168.1.x 5269” is ok on Server B and “telnet 192.168.1.xx 5269” is ok on Server A.

Step 1:

add “192.169.1.xx imb” to “C:\windows\system32\drivers\etc\hosts” file on Server A;

add “192.169.1.x ima” to “C:\windows\system32\drivers\etc\hosts” file on Server B;

Step 2:

add “imb” to “Server to Server” configuration on Server A

add “ima” to “Server to Server” configuration on Server B

Step3:

IF you login Server B and want to add user(s) who login Server A, you can use this: “[username@ima]”

IF you login Server A and want to add user(s) who login Server B, you can use this: “[username@imb]”

I test many times, all is ok!

wish you success!

Ok but what tells server A to even look at server B??

There really isn’t anything in server to server tab that tells server a that server b even exists or b to a