powered by Jive Software

Server-to-server works one side only

Openfire 3.7.0_1,1 on Freebsd 8.2 x86 - installed from the ports.

ipfw (firewall) allows all connections on port 5269.

all dns records are good .

server to server service is enabled, Allowed to Connect - anyone

security settings - optional (and i’ve tried with custom - without checkbox)

domain for example - xxx1.com

all is good between clients x1@xxx1.com and x2@xxx1.com

but it is another big public xmpp server - yyy2.com

and something bad between x1@xxx1.com and y1@yyy2.com:

authorization not working

online-status not working

messages are delivered to x1@xxx1.com from y1@yyy2.com !!!BUT not delivered from x1@xxx1.com to y1@yyy2.com - like to black hole - but i see a lot of connections on 5269 in tcpdump and all looks like it should be

what is wrong?

PS. sorry for my bad english

Most issues with s2s on 3.7.0 are probably related to this bug OF-443. Suggest to use 3.6.4.

yes, i think this is a reason

i’ve tried to set this:

Server Settings - Security Settings - Server Connection Security - Custom - TLS method - Not Available

and restart openfire and messages now sends to @jabber.org accounts, but @ya.ru @qip.ru and @gmail.com still don’t work

do anyone knows how to install 3.6.4 on freebsd? because there is 3.7.0 version in ports