ServerStarter classpath on /bin/openfire

Hey guys,

I have downloaded Openfire latest binaries (4.7.4) to upgrade from 4.4.1, after placing the binaries and set up config files I tried to start it with a /usr/lib/systemd/system/openfire.service previously configured.

Then I noticed it was failing because new /bin/openfire startup was trying to find the ServerStarter class in this path:

Which, checking v4.7.4 source code doesn’t exist, the one that exists is located on


I tried to look for the intended path, but for the life of me couldn’t. So I ended up replacing the path discarding the install4j part.

Anyways I would like to check with you guys what I’m missing, maybe I’m looking in the wrong place or I missed some configuration step.

Thanks in advance and best regards!

That’s weird. Install4j is a third-party application that we use to generate installers. Maybe you have mixed installers, using an install4j one previously, and now one that is not install4j based (or the other way around)?

Hey Gus,

It is weird, I literally just downloaded openfire_4_7_4.tar.gz for linux from the Ignite DOWNLOADS page, from those sources. You can check it yourself on /bin/openfire, on line 489:

"$local_classpath" start > /dev/null 2>&1 &

and from that line forward every single ServerStarter call has that path

Let me know your thoughts,