Services not loading up


Im running a fresh installation of Openfire3.5 on my linux machine and I have hit a snag in which with either Spark, PSI & Pidgin, I cannot detect or browse the services. It will not give you a means to login to AIM, MSN, ICQ, Browse the MUC’s…nothing. Its not giving any error messages on client PC or jabber apps. Its just not loading anything. Also, its giving me a “failed to connect” error on every 1st attempt I make to set my vcard.

I ran the previous 3.4 series as well and this is the 1st time I ever came across this issue. Is this a bug or am I the only guy having the issue? If there is any idea what I can do to straighten this out let me know.


Im gonna take it Im the only guy so far dealing with this issue.

Seriously do you guys need any other info? Anything? about 50 or so on-lookers but none have an idea about this issue with “service discovery” not working? I really need help getting this ressolved. As I honestly DO NOT wish to drop back to 3.4 if I can help it.


This I felt would be best to include in this thread then just starting a new one. Now all of a sudden Openfire stopped allowing either of my accounts to connect.Unfortunately, Im not certain of what I am looking at.

I keep getting this in the XML console…

<?xml version=“1.0”?>

<stream:stream xmlns:stream=“” xmlns=“jabber:client” to=“” >

<?xml version=‘1.0’ encoding=‘UTF-8’?><stream:stream xmlns:stream=“” xmlns=“jabber:client” from=“” id=“fefc1936” xml:lang=“en”>

<iq type=“get” id=“auth_1” to=“” >

<query xmlns=“jabber:iq:auth”>




<iq from=“” type=“error” to=“” id=“auth_1” >

<query xmlns=“jabber:iq:auth”>



<error type=“modify” code=“400” >

<bad-request xmlns=“urn:ietf:params:xml:ns:xmpp-stanzas”/>



Thank you

This is an issue that unfortunately was not ressolved by upgrading to Openfire 3.5.1

I still have not recieved a viable answer from anyone as to what might possibly be causing it or how to work around it. Other than the suggestion to upgrade to 3.5.1. However, I am able to once again connect to the server. But still, I cannot get any of the aformentioned clients to pull up any service discovery features. I checked the server’s settings at least three times already and still I am not making any headway as to why I seem to be the only guy with this issue. I am beyond baffled as to what it could be. All I know is 3.4 worked fine. Whatever was changed in 3.5 is causing havok with allowing anyone here to detect any services.

All in all, this is a problem that is unressolved and due to it, against my better judgement Im dropping back down to 3.4 unless someone has an interest in catching me to explain why this is not working and maybe even suggesting what I can do to ressolve it.

Thank You

Did you upgrade the IM Gateway plugin? Did you check to make sure you are up to date on all of your plugins? Anything in the error logs that looks promising?

It may seem like a stupid question and i do not mean to offend, but. Did you install and configure the gateway plugin? Install the plugin is only the first part. You must also enable each protocol you wish to allow. If you did this and still have no luck. Then download the plugin directly from the ignite website ( Stop your server from running. Delete the existing gateway.jar and the folder it created. Copy the newly downloaded plugin in to the folder. Restart the server and test.

Hey no offense at all!

See, Im not what you’d call the highly technical minded. So, Im prone to miss things. Plus as I was always told in the service: “Theres no such thing as a stupid question”;). Im just highly appreciative to finally get some replies on this!

Ok, everything was setup and configured as it was before when I was running 3.4. So, all the services were installed, configured and running. I’ll try the method you suggested and report back if it was a hit or miss!


The plugins I nabbed were the ones that were “Available” in the Plugins tab. I can check to see if they are. Especially the IM Gateway one. Im not really seeing anything in the logs that might have a relation to the issue. Also, its not just the IM gateways, but Search and MUC browsing wont load up either.

It definitely sounds like you have outdated plugins. Deleteion of the plugins and their folders should cure your problems. Plus the new version of openfire is out now (3.5.1) that gives you more options and fixes many issue.

Ok, I once again verified the plugins were up to date. But either way, I did as instructed and deleted the plugins from the list. Stopped the server and I am now in the openfire folder & there is no trace of those plugins or their folders lying around.

Yeah, 3.5.1 is the one Im running. I nabbed it early this morning after being advised by another developer in the chat that it might be the fix to this issue. So far it was’nt. I did however notice that ALOT of my settings were still in place when I tried to do an uninstall and then install the newer version. So, I am going to try doing a full uninstall and see if that helps.

I’ll update you guys in approximately 30-45mins.

I know this is WAY off the subject but since I am already getting ready to do a complete full reinstallation of Openfire 3.5.1. I felt inclined to ask if any of you knew what is the deal with the latest MySQL5.0? I am having a time getting it to properly install & start up either through my distro’s repo or off the MySQL site.



Somehow or another its working after a fresh reinstall of my OS.

Now Im wrought with a new issue. Im trying to follow your guide for importing the schema to a table in MySQL but I keep getting an error saying its the wrong command. Is there anyone else that uses a version of MySQL that needs ANOTHER set of commands to import schemas?

Message was edited by: phyerboss