powered by Jive Software

Session disconnecting

In my organization we’re facing a problem where the client sessions are disconnecting with no reason. I’ve tried to increase resources in my VM, update Openfire version and the same error shows up. If someone gets disconnection the status in PSI stays Online and he can receive any message unless that he changes the status to offline and online again.
Here are some info:
OPENFIRE_OPTS="-Xms256m -Xmx3072m"
Openfire 4.3.0
CentOS 7
Error Log:
2019.04.12 12:03:59 WARN [socket_c2s-thread-11]: org.jivesoftware.openfire.nio.ConnectionHandler - Closing connection due to exception in session: (0x000000CE: nio socket, server, / =>

Could someone help me, please?

1 Like

When someone gets disconnected, what it shows for this user in Admin Console? Is it still showing on Sessions page? Is it showing as online on Users page? You should update to 4.3.2, there were a few bugs fixed that could be related and needed to make a change if your issue is what i think (Stream Management related).

1 Like

In the admin console it shows that the user is Online.
I had the same issue in the 3.9.3 version and the update to 4.3 the issue had gone. There is a note in the patch note of 4.3 that this issue was solved.

I will schedule a new update and test.
Thank You :slight_smile:

I have the same question in 4.3.2. and I login second by the usr that online and the same session .the second session will be droped in about 10 min

I has just updated my server and the error persists.

You can try adding a system property stream.management.active with a value false. This will disable SM, which tries to keep sessions for disconnected users online, so they don’t have to reconnect (good for mobile users). Then see if that changes anything about your issue.

I’m going to create and wait. Thank you for the help (:

I think this setting should work immediately, but i still suggest restarting Openfire after creating it.

I’ve set the stream.management.active false and everything is working fine.
Thank wroot. U ROCK

1 Like

Hi all
Psi maintainer is here! :slight_smile:

@wroot, I don’t know why but only OpenFire users complaining about this problem and disabling SM on client side is always a solution.
Is it some problem with SM in OpenFire?

Could be. But also depends on a version of Openfire. There was a bug in SM in older versions.

I just installed 4.4.0 on localhost. Seems to work fine with SM.

Hi rion!

What is the SM and how may I disable it?
Thank you

You already marked this discussion as solved, so i’m puzzled. SM is short for stream management, which i believe you have already disabled.

Yeah, I have disabled it. I was just curious to know.
Thank you again (: