Setting up Openfire to work with LDAP on SBS2003

I am trying to install OpenFire 3.6 on a server. This server is a member server of our network. Our DC is a SBS2003 server. The attached pdf file has screen captures of my setting and the error that I am getting.

I have read the documentation and looked other post on this site about this problem but still can not get past this.

Hope someone can help me out with this.

openfire.pdf (66451 Bytes)

your host can simply be WMKL.local, this does not need to change though. your baseDN should be ou=MyBusiness,dc=WMKL,dc=local, because your groups are directly below this OU.

Thanks Todd,

that seems to have solved that problem. But once the wizard is done and I try to log onto the admin console I just see the message below. I have tried accessing this page from different computers but I get the same thing.


java.lang.NoClassDefFoundError: Could not initialize class org.jivesoftware.admin.LoginLimitManager$LoginLimitManagerContainer
     at org.jivesoftware.admin.LoginLimitManager.getInstance(
     at org.jivesoftware.openfire.admin.login_jsp._jspService(
     at org.apache.jasper.runtime.HttpJspBase.service(
     at javax.servlet.http.HttpServlet.service(
     at org.mortbay.jetty.servlet.ServletHolder.handle(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.util.LocaleFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.admin.PluginFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.jivesoftware.admin.AuthCheckFilter.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(
     at org.mortbay.jetty.servlet.ServletHandler.handle(
     at org.mortbay.jetty.servlet.SessionHandler.handle(
     at org.mortbay.jetty.handler.ContextHandler.handle(
     at org.mortbay.jetty.webapp.WebAppContext.handle(
     at org.mortbay.jetty.handler.ContextHandlerCollection.handle(
     at org.mortbay.jetty.handler.HandlerCollection.handle(
     at org.mortbay.jetty.handler.HandlerWrapper.handle(
     at org.mortbay.jetty.Server.handle(
     at org.mortbay.jetty.HttpConnection.handleRequest(
     at org.mortbay.jetty.HttpConnection$RequestHandler.content(
     at org.mortbay.jetty.HttpParser.parseNext(
     at org.mortbay.jetty.HttpParser.parseAvailable(
     at org.mortbay.jetty.HttpConnection.handle(
     at org.mortbay.thread.QueuedThreadPool$

I have no idea what that error means. Do you have any plugins installed? If you do i would delete them manually from the plugins folder and their folder that they plugin jar file created. To do this you must stop the openfire server first. Also how many users do you have?

thanks for your help. I was looking around last night and checked the error log and saw that it was trying to access a SQL and I had not set that up. In fact I was only going to use the internal db since I only have 45 people that will use this.

Thanks for your help.