powered by Jive Software

Setting up pyMSNt windows "no module named xish.domish" problem

Hi,

been following the thread http://www.jivesoftware.org/community/thread.jspa?messageID=110183&#110183 and search the forums and can’'t find an answer to my problem.

  • Windows 2003 Web edition

  • Installed Wildfire 2.4.2

  • Installed Python 2.4 (c:\python24)

  • Installed Twisted Library 2.1

  • Installed Python Image Library 1.1.5

  • Extracted pyMSNt to c:\pymsnt-0.10.3

  • Followed instructions on http://msn-transport.jabberstudio.org/docs/server.html to the letter.

When I try to run pyMSN (main.py) I get the following error message:

Traceback (most recent call last):

File “main.py”, line 4, in ?

import utils

File “C:\pymsnt-0.10.3\src\utils.py”, line 134, in ?

from twisted.xish.domish import SuxElementStream

ImportError: No module named xish.domish

I thought that module was installed with the Twisted library… but I have no idea what the problem is. Can anyone shed some light on this? Have I done something wrong?

thx

I think i had the same error did you get pycrypto because i think thats all i did to get it to work tell me if it does

You can get it form here

http://www.amk.ca/files/python/crypto/pycrypto-2.0.1.tar.gz

Thanks for the reply. I installed pyCrypto prebuilt binaries (from here http://www.voidspace.org.uk/python/modules.shtml#pycrypto) but I still get the same error message. Any other idea what you did to solve this?

No sorry thats what i did

But just maybe if you try Uninstalling all of the of the python stuff and install it in this order

Python 2.4

Twisted for Python 2.4

PyCrypto for Python 2.4

PyOpenSSL for Python 2.4

if you cant find or dont have any of the above files just ask

Would you know the where I can find precompiled windows binaries of pyOpenSSL for Python 2.4? The available ones on sourceforge are for python 2.2

Thanks again

http://webcleaner.sourceforge.net/pyOpenSSL-0.6.win32-py2.4.exe

found it in thread …

http://www.jivesoftware.org/community/thread.jspa?threadID=15291

or you can go to

ftp://cybermikec.homeip.net/python%202.4

Then download the pyopenssl (its the python 2.4 one)

and the rest of the files need are also there

Thanks for the help guys, but still no joy I’‘ve unintstalled everything, and installed in the order cyber_mm suggested but still getting the error message. Tried it on a couple of other windows machines also. I’'m not a python head ( c# is my poison) so feeling a little frustrated. Damn this sucks.

Ok, any last ideas?

Ok, got it working. Not sure how… I’'ll post a message tomorrow when I know exactly what I have done. Thanks for the help.

The reason I was getting the original error message was because the Twisted library was not installing properly. At the end of it’‘s installation process, the Twisted library is precompiled. My precompilation was failing, but I didn’'t notice '‘cos I’'d never installed it before.

I was hacking around the various py files in pyMSNt to see if I could get it to use the included, older, tlib.domish and was making some progress. I had started getting various DLL not found and entry point error messages. I had seen similar messages in cyper_mm earlier thread and new it was something to do with libeay32.dll. I had a copy of that dll but nothing was working. Googling around, worked out libeay32.dll was OpenSSL. A forehead slapping moment occured and I installed the latest OpenSSL windows binaries. Then reinstalled pyOpenSSL, pyCrypto and then Twisted (in that order)… a python precompiling dialog appeared at the end of the Twisted install and I knew I was on to something…

It ran after that.

Thanks for the help guys.

Hello Burth,

I’‘m getting the same error message. I’'ve installed Win32OpenSSL-v0.9.8a.exe like you said and reinstalled openSSL, crypto and twisted but still getting the same error. do you have any idea to solve this issue? and do i have to compile twisted packages ?

thanks

I’‘ve been meaning to do a clean install and document each step (and to learn where I went right…) I probably won’‘t get time to do this until the weekend. I’'ll post as soon as.

AFAIK, you don’'t have to compile twisted packages yourself. The installer will do that for you.

On another note, I’‘m finding pyMSNt to be very unreliable. There’‘s lots of error messages and stack traces being dumped on screen. It seems to continue to run, but it can take several minutes for me to appear online on MSN (I’'m using the exodus client), if at all. Sometimes I have to log into my server and restart pyMSNt.

So far a dissapointing experience.

Thanx for replying,

Well I tried to reinstall all packages but nothing changed, the only difference is that i’‘m using windows XP and i guess this is the problem (i’‘m not sure). Any way the twisted installer doesn’'t seem to be compiling any thing.

Regards…

Hey guys, any more info you can provide?

While I am not using Windows (FreeBSD 5.4 here), I am experiencing the same;

ImportError: No module named xish.domish

Error when I am trying to run any of the pyAIM/pyMSN components.

When I try and install TwistedSumo 2.1 (2005-11-06), I noticed that I also get a message;

package init file ‘‘twisted/plugins/init.py’’ not found (or not a regular file)

package init file ‘‘twisted/plugins/init.py’’ not found (or not a regular file)

Can anyone shed some light for me? This is driving me nuts! As far as I can Python is installed and running fine… it’'s just Twisted that is getting in my way…

I’'m also experiencing this problem on fedora core 4 using the same version of twistedsumo and the latest pyMSN pymsnt-0.10.3

when i run python main.py

i got the following error:

Traceback (most recent call last):

File “main.py”, line 4, in ?

import utils

File “C:\Program Files\wildfire\Transport\pymsnt-0.10.3\src\utils.py”, line 13

4, in ?

from twisted.xish.domish import SuxElementStream

ImportError: No module named xish.domish

i have installed python 2.4, twisted 2.2.0, pycrypto 2.0.1, pyopenssl0.6 in that order…all binaries…

i even include the libeay32.dll to the windows/system…

how did uguys solve the problem?

C:\Program Files\pyaim-t-0.7b\src>c:\Python23\python.exe main.py

Traceback (most recent call last):

File “main.py”, line 4, in ?

import exception

File “C:\Program Files\pyaim-t-0.7b\src\exception.py”, line 6, in ?

import debug

File “C:\Program Files\pyaim-t-0.7b\src\debug.py”, line 7, in ?

import utils

File “C:\Program Files\pyaim-t-0.7b\src\utils.py”, line 57, in ?

from twisted.xish.domish import Element

ImportError: No module named xish.domish

Needing help…

its hard to get help here…

anyway, have u installed twisted? if u did…go to the python24 folder Lib\site-packages\twisted\words\ and copy the xish folder out to the twisted\ folder

it should solve the problem…otherwise go into the .py file and change the twisted.xish to twisted.words.xish…

Ok got rid of that one… Thanks.

Now I’'m getting…

C:\Program Files\pyaim-t-0.7b\src>c:\Python23\python.exe main.py

WARNING! Only PNG avatars will be understood by this transport. Please install t

he Python Imaging Library.

c:\Python23\lib\site-packages\twisted\web\proxy.py:22: DeprecationWarning: twist

ed.protocols.http has moved to twisted.web.http. See http://twistedmatrix.com/pr

ojects/web.

from twisted.protocols import http

No valid XDB driver specified, exiting…

Traceback (most recent call last):

File “main.py”, line 110, in ?

import xdb

File “C:\Program Files\pyaim-t-0.7b\src\xdb_init_.py”, line 9, in ?

exec(“from %s import XDB, housekeep” % xdbDriver)

File “”, line 1, in ?

File “C:\Program Files\pyaim-t-0.7b\src\xdb\mysql.py”, line 11, in ?

import MySQLdb

ImportError: No module named MySQLdb

ur first problem

http://www.pythonware.com/products/pil/index.htm

get PIL.

ur 2nd problem, i’‘m not really sure what’'s causing it.