powered by Jive Software

Setup good then cannot login

Here is the background and issue. Fresh

Install of openfire 3.4.1 in windows server 2003 R2. The openfire

install was done with the embedded DB and Active Directory. Thru-out

the setup in testing the environement everything passed—the base dn,

administrator dn, samaccounts, groups all seem fine. After install I

can launch the admin console and login fine as me. At this points

clients can attach and everything seems fine

The probelm occurs after I restart the application and then try to login to the admin console, i get denied. I varified that the username is

in the admin list, the only plug-in is the search one. And no default

settings were changed. In addition at this point the clients cannot

attach either.

One additional coincident is that if i go to the setup before

restarting the application under security certificates there is a

banner at the top of section that states that the web server needs to

be rebooted. Once I do that the admin console closes and the login

denies me.

Hi,

Looks like Openfire failed to start.

Did you change and use your own certificate? What does log/error.log say?

It seems that it starts or at least the app says it has started and the admin console is listening at http://machinename.domain:9090 and https://machinename.domain:9091

No I did not add any certs myself it seems that there are some self signing ones created on install and that is where the web server restart comes in?

Attached is the error log

We are behind a firewall right now so a lot of the errors lool like communication errors

Error reading XML properties

org.dom4j.DocumentException: Error on line 64 of document

It doesn’t look like a communication error to me. Could it be an XML parse error in your conf/openfire.xml file, probably where you define the LDAP properties?

I have the same problem. It seems like after restarting openfire server it losing AD profiles and not renewing after restarting. I have to delete “true” value in the “jive” section of conf file and make it again…

So in changing this value to either false or “blank” i just get the setup offered to me again. Is there something I am missing here? What are you chaging the value to in

<setup>true</setup>

Is that even the value you are talking about

Hi,

if you change " " then the setup should be run again when you start Openfire. This will allow you to enter the LDAP connection data again if you can not modify the wrong entry in your XML file.

If this is really the case I’d like to know what you enter in the web console and what Openfire saves in the XML file. Remove sensitive information before posting it here. It it an ‘&’ as search filter or an ‘&’ somewhere within a password? This should help to identify and fix this problem.

See also JM-1101 - if you are using non-ASCII characters somewhere they you may get a broken openfire.xml file.

LG

I’ll give you more info as soon as i will be at work… But i have to say, that i’m not using non-ASCII characters in server configuration. I’m beginner at using openfire. Can you tell my if it is necessarily unique to edit a xml file or i can do the same by Web Interface.

LG, yes the admin admin password has an “&” in it. Is that what could be breaking things? Because during setup the testing process is fine like I mentioed before but in the openfire.xml file in place of the '&" is “amp;amp” in the admin password.

If I were to use the <foo>å ä ö</foo> in the openfire.xml file where does it need to go the doc type at the top is speciafed as UTF-8 by default

<?xml version=“1.0” encoding=“UTF-8”?>

Thanks for the help!

LG, Yes!!! I forgot, that my administrators OU name in AD is named in Cyrillic characters… Thanks!!! After renaming OU in latin characters it becames all right!!!

xavchik, how did you do that?

What are you talking about? I didn’t understand?

“renaming OU in latin characters it becames all right!!!” How did you rename the OU in Latin Characters

Hi mm519,

I guess that xavchik had specified “uid=cyrilicname,ou=persons,ou=example,dc=com” as the admin dn, so it was quite simple to change, or he did add a new one with “uid=abc,ou=persons,ou=example,dc=com”.

LG

Run mmc console snap-in “Active Directory - users and computers”, go to Organization Unit (OU) and rename it… The name “???” change to “Administaration”, That is all.

Hi,

if you already pass an Xmx value to java then you may want to pass also “-Dfile.encoding=UTF-8” to the java process. This should solve the problem.

LG

So an intresting thing I discovered is if I start the windows “Openfire” Service then launch the openfire application I get these errors

Database setup or configuration error: Please verify your database settings and check the logs/error.log file for detailed error messages.

java.lang.IllegalArgumentException: java.lang.NullPointerException

at org.jivesoftware.openfire.XMPPServer.verifyDataSource(XMPPServer.java:714)

at org.jivesoftware.openfire.XMPPServer.start(XMPPServer.java:433)

at org.jivesoftware.openfire.XMPPServer.<init>(XMPPServer.java:155)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.openfire.starter.ServerStarter.start(ServerStarter.java:105)

at org.jivesoftware.openfire.starter.ServerStarter.main(ServerStarter.javaError starting the server. Please check the log files for more information.

:50)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

Caused by: java.lang.NullPointerException

at org.jivesoftware.openfire.XMPPServer.verifyDataSource(XMPPServer.java:703)

… 16 more

Server halted

But if I turn the service off and launch the application it seems to start cleanly.

I still have clients and the console failing to connect after I go thru setup.

So where does “-Dfile.encoding=UTF-8” go in the openfire .xml file and if so where in the file?

Thanks!

OK so I figured out my problem. The administrator password has a “&” in it. During the setup obviosly the ascii character works ok but in the openfire.xml file the character is “&amp;” which did not work so I changed it to “&” and now it works.

Hi,

place it in the vmoptions file which is used to change the Xmx memory value, read the documentation for the right name and place of this file.

You must not start the Openfire service and the Openfire console. It’s either or.

If the service is running and you want to access the web console then simply open your browser and go to http://127.0.0.1:9090/

LG