Setup Help

I am trying to set up the Wildfire server and in the Wildfire documentation for MySQL is says

Import the schema file from the resources/database directory of the installation folder:

Unix/Linux: cat wildfire_mysql.sql | mysql ;

Windows: type wildfire_mysql.sql | mysql ;

I am confused on what that means, I have tried that command and it doesn’'t work.

Also, when I am setting up Wildfire with MySQL it asks for a username/password. When I installed MySQL I made a root password, but I dont understand what Wildfire is wanting.


  1. What OS are you running the Wildfire on? I will guess that it is some flavor of linux/unix… If you are on a Windows box… I can’'t help ya.

  2. Import the schema file: This is used to populate the database with the proper table fields and settings. If you are new to MySQL this can make thing a lot easer. You may want to use a tool called webmin ( to setup and configure MySQL. It is a free web based GUI tool and under the MySQL section ther is a import function for schema files.

3.The reason you are being asked for a password is that the DB access is required to have authentication. You did setup a account “Root” for MySQL, this can be used but you should consider setting up a second account that access to only that service such as “MySQL” or “wildfire” and use a differnt password than root’'s. This can be done very quickly in webmin.


I want to run Wildfire on an existing Windows server. But if that is too much trouble I could set up a Linux server.

Does anyone know of a webmin-like tool for Windows?

edit: I noticed there is webmin for windows, but I can’'t extract the archive.

Message was edited by: jwcmonkey

Installing on Windows (From

Recent Webmin versions can be installed and run on Windows, although with limited functionality as not all the servers that Webmin configures (such as Samba, Sendmail and so on) are available. The steps to install on Windows are :

  1. Install winzip or pkunzip so that you can extract the .zip file linked to above.

  2. Install the latest versions of ActiveState ( ) Perl for Windows.

  3. Install the process.exe ( ) program, a command-line tool for listing and killing Windows processes.

  4. Verify that sc.exe is installed. This is part of Windows XP, and may be found in the Windows Resource Kit on other versions of the OS.

  5. Install the Win32::Daemon ( ) Perl module.

  6. Create the c:\temp directory if it doesn’'t already exist.

  7. After extracting the Webmin ZIP file to c:\webmin , open a command shell window, cd to that directory and run perl

  8. Answer all the questions as you would for a tar.gz install of Webmin, as documented above.

I hope this helps.

Look on the bright side, If you go to a Linux/Unox server you will save some money by not giving it to Micro$oft .


I downloaded Webmin for Windows, but the .zip file is corrupt or something and I can’'t unzip it.

Actually by using the existing Windows server I have I will save money, if use Linux for this I will need to have another server.

If you don’‘t want to install and use Webmin here’'s how you do it

Start with creating a database in MySQL for Wildfire if you haven’'t done it yet

by opening the command prompt (Start, Run: cmd) and enter the following command:

mysqladmin -u root -p create wildfire

Enter the password for the root account when prompted

If you installed Wildfire in the default path then you can import the schema to the database by executing:

type %PROGRAMFILES%\Wildfire\resources\database\wildfire_mysql.sql | mysql -u root -p wildfire

Enter the password for the root account when prompted

I have the database created as “wildfire”

I noticed when I use the mysqladmin command I have to point it to the location. For example, if I needed to create a database I would do:

c:\MySQL\bin\mysqladmin -u root -p create databasename

Why do I have to do this?

When I try to import the schema using the command you gave me I get:

The system cannot find the file specified.

Error occurred while processing: C:\Program.

The system cannot find the path specified.

“mysql” is not a recognized command, etc

I tryed pointing mysql to c:\MySQL\bin and I got:

The system cannot fine the path specified.

Any idea?

The fastest and easiest way is probably to just copy the file “wildfire_mysql.sql” from “Wildfire\resources\database” folder and then paste it in the “c:\MySQL\bin” folder (if that’'s where you installed MySQL).

Then open the command prompt and change to the “c:\MySQL\bin” folder by executing:

cd c:\MySQL\bin

(if the prompt wasn’'t already on the “C:” partition, for example “D:\some_folder” then execute: c: )

and then run the import:

wildfire_mysql.sql | mysql -u root -p wildfire

When you installed MySQL you could have selected the option “Include Bin Directory in Windows PATH” (it’'s not selected by default).

All the folders that are added to the PATH variable gets searched

when Windows tries to locate a program. You can add it manually if you

want to be able to run mysql from wherever.

Rightclick on “My Computer”, choose “Properties”, select the

“Advanced” tab, click the “Enviroment Variables” button, select the

“Path” variable in the list of system variables and click “Edit”.

Now add the path to the bin folder at the end of the list but don’'t forget to add a ; before the path like this


You might have to reboot your system before the “bin” folder has been added to the PATH variable (I’'m not sure).

Now try to run the import again:

type “%PROGRAMFILES%\Wildfire\resources\database\wildfire_mysql.sql” | mysql -u root -p wildfire

Personally I think it’'s worth it to add it to the “bin” folder to the

PATH variable because you never have to “be” in the folder where MySQL

is (or type the whole path every time).

Message was edited by: FreaKBrother

hey, it works!

Thanks everybody for your help.

Message was edited by: jwcmonkey