Setup woes


I’'m trying to setup WildFire 3.0.1 on CentOS. After successfully completing Setup, going to /login.jsp?username=admin redirects me back to Setup … what gives? hehe. inspecting wildfire.xml and it looks like none of my setup values ever get set (…from browsing around the forum and seeing ‘‘full’’ setups I infer this…)

Everything goes ok … well, here’'s exactly what i did in a line by line, piece by piece log :confused:

  1. my steps i wrote down as i attempted this ################


Make sure that you are using MySQL 4.1.18 or later (server has MySQL - 4.1.20)

jre 1.5


jre 5.0 R6 to server dir

wildfire tar.gz to server dir

chmod a+x jre-1_5_0_08-linux-i586.bin

./jre-1_5_0_08-linux-i586.bin -localinstall

tar -xzvf wildfire_3_0_1.tar.gz

download ./wildfire/resources/database/wildfire_mysql.sql

create wildfire db in mysql on localhost

import .sql file

  1. edit the following file to include unicode support mysql [for unicode

  2. conversations]

emacs ./wildfire/conf/wildfire.xml

  1. replace the last line </jive> with the following.

  2. <!-- My custome MYSQL section to support unicode strings. -->

  3. <database><mysql>useUnicode>true</useUnicode></mysql&gt ;</database>


mv wildfire /opt

cd /opt/wildfire/bin

export JAVA_HOME=/usr/java/jre1.5.0_08/bin/

./wildfire start

  1. in browser goto

  1. in setup now #

  2. english

  3. domain:

  4. admin port: 9090

  5. secure admin console port thru SSL: 9091

  6. jdbc:mysql://[host-name]:3306/[database-name]

  7. to

  8. jdbc:mysql://localhost:3306/wildfire

  9. dbuser // be sure db user has access to that database.

  10. // got 1 failure message when the db user didn’'t have permissions for that database…

  11. // hopped into phpmyadmin and fixed it…

  12. dbpass

#admin email:

  1. ps: bluesky3704

redirects to setup.jsp? what did i do wrong?

add <setup>true</setup> to last line of wildfire.xml before </jive> # still no go…

  1. end of my steps ################




Message was edited by: davidm29

Message was edited by: davidm29

Message was edited by: davidm29

Message was edited by: davidm29


you could try to add to the trusted sites in IE if you are using it or use Firefox and enable cookies for this page.

Is user foobar running Wildfire? And if it is does it own the /opt/wildfire directory and sub directories? So can it write wildfire.xml?


Thank you.

You are correct I did not have a jive or any user except root to run the process so I created a “jive” user and gave them ownership of the directory sub-structure.

BUT, that wasn’'t the cause of my problem!!! :stuck_out_tongue:

stare at my stoopid code posted originally and be enlightened by this:

  1. replace the last line with the following.

  2. useUnicode>true


I am only human…and lord knows I dont check error logs enough :stuck_out_tongue: example:

2006.08.23 19:46:10 org.jivesoftware.util.XMLProperties.buildDoc( Error reading XML properties

org.dom4j.DocumentException: Error on line 79 of document : The element type “mysql” must be terminated by the matching end-tag "(

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(

at org.jivesoftware.wildfire.starter.ServerStarter.main(

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.install4j.runtime.Launcher.main(Unknown Source)

But it was in my documentation above

Thank you for your help.


Is this a typo? where is the < ?


Message was edited by: jeff_garner