SEVERE: Unable to load plugin Fastpath Service due to no minSparkVersion

Aug 19, 2008 11:22:31 AM org.jivesoftware.spark.util.log.Log error
SEVERE: Unable to load plugin Fastpath Service due to no minSparkVersion.

Hello, I’m trying to get this set up, however I can’t seem to get the fastpath plugin to load. I’ve reinstalled Spark multiple times.

Spark Version: 2.5.8

Openfire: 3.5.2

Fastpath Openfire Plugin: 4.0.0

When reinstalling Spark, I make sure to completely remove the Spark directory before reinstallation.

Any ideas?

I would really appreciate some help.

Are you using the client control plugin as well? If not install it and set the spark versions, by placing the .exe, .tar.gz, and dmg versions on your server. This is just a guess but that seems to be what it is asking for. I am doing this aready and have never seen this error.

Yes, I’m using Client Management and I’ve loaded the current .exe, .dmg and .tar.gz

I’d also like to mention that I have another user who’s able to load the plugin correctly. I’m using the exact same installer and plugin. For some reason, however I still receive the message above and Fastpath does not load for me.

Just for the records (because I ran into the exact same error while doing some plugin development): the error is caused by a missing minSparkVersion element in de plugin xml.

– Henkk