powered by Jive Software

Shared roster groups bug/presence not updated

Setup: Wildfire 3.2.2, 150 users on server, every user is member of one big shared contact list group (so that each user of the server is subscribed to each other user). About 30 users are online.

Problem: User presence seems only to be up to date directly after login but never gets updated.

This is the same on another server of mine running Wildfire 3.2.0 and a similar number of users.

A quick check with a two user installation doesn’'t show this error.

Is the shared roster feature in use somewhere else? Or did I something wrong in both setups? How to debug this?

Did some more tests. I set up Wildfire SVN locally, added 150 users to one shared group. Seems to work fine. One odd thing though: In the testing (working) server, presence subscription is shown as “both”, while in my normal 3.2.2 installation (that exhibits the bug) presence is only “to”. In the 3.2.0 installation (that also exhibits the bug) subscription is “both” again (no typo). Any ideas?

Seems we solved this. In the 3.2.2 server, due to some LDAP oddities, there were quite a lot of groups that were more or less garbage (and partially ‘‘Active’’ but without any name). Seems this confused the server. We set up an LDAP group filter (configuration property ldap.groupSearchFilter) which solved the issue.

On the 3.2.0 server, I think the issue is a different one (and hopefully is fixed once I upgrade that server to 3.2.3).