powered by Jive Software

Single Sign on for Openfire XMPP using Spark

Hi I followed below steps to Single Sign on for Openfire.

28 Steps to Single Sign On for Openfire XMPP Server on Windows Server 2012 R2 with Spark

Below are My Server details

Active directory Server :

Server IP : aaa.bbb.ccc.dd

Server Domain : abcdef.LAB

Server Host : ADServerHostName

Service Account in AD for openfire: xmpp-openfire

Sevice Account Password in AD : xxxxxxxxxx

OS : Windows 2008 R2

Openfire Server

Server IP : pp.qqq.rrr.sss

Server Host : OpenfireServerHostName

Server Domain : abcdef.LAB

OS : Windows Server 2016

Openfire Details :

xmpp.fqdn : OpenfireServerHostName.abcdef.LAB

I have installed Spark in Openfire Server itself to act as Client. If I set System Property sasl.mechs to PLAIN, I am able to login using the Active Directory User and Password. However I do not want to provide the password for logging in again. So I set sasl.mechs to GSSAPI. When I Changed to this property, I am getting below error.

Feb 27, 2017 12:44:50 AM org.jivesoftware.smack.util.DNSUtil resolveDomain

WARNING: Exception while resovling SRV records for OpenfireServerHostName. Consider adding ‘_xmpp-(server|client)._tcp’ DNS SRV Records

javax.naming.NameNotFoundException: DNS name not found [response code 3]; remaining name ‘_xmpp-client._tcp.OpenfireServerHostName’

Please let me know where I am making mistake or I have missed any settings

Thanking in advance.

Sheshagiri