powered by Jive Software

Single user cannot sign in out of 137 users

Openfire 4.2.3 running on windows.
We do not have issues with anyone but just a single user trying to sign in from spark client.

This user was signed in and his computer crashed which required a new computer.
We are in a domain and openfire syncs with LDAP.

When the user tried logging in using spark he received username/password error.

When you go to users in the server only his new machine name shows (not his username)
And in groups, his name shows as user@server.domain.com* (with a red astrix at the end.)

We waited 3 days, cleared all caches, restarted openfire, reset his AD password, we have done basically all we can think of.
Checked LDAP testing and passed …

What are we missing ?

EDIT: We can create a new user in AD and immediately sign on in spark with that user, LDAP is working… it just seems this ONE user is cached somewhere some how and I really do not want to recreate this user in AD, I am unsure if that would even matter at this point.

EDIT2: error in error log shows this when user tries to sign in:
2018.10.29 06:57:50 org.jivesoftware.openfire.roster.Roster - Groups ([SparkUsers]) include non-existent username (abuda)

FINAL EDIT (maybe):
So it seems to be working now for this user.
Clearing the cache, restarting did not seem to work, but it seems maybe removing him from the AD group, clearing the caches, and readding him to the AD group in a specific order is maybe what has fixed it. We will see