SIP Phone Plugin not working in Spark

I have SIP Phone Plugin installed openfire 3.5.1 and SIP Softphone Plugin installed in Spark 2.5.8. In Spark, it won’t registered. When I go to openfire, click on Phone, it says “RegisteredFailed”. I have installed Asterisk-IM Plugin in openfire and have it setup and working. But for SIP Phone Plugin, it is not working. Both plugins, asterisk-im and sip phone have the same concept where connect plugin to asterisk server.

Any suggestions?

I got it to work for others who are having the same trouble.

spark 2.5.8, openfire 3.5.1

in openfire, delete phone mapping for user in Phone, deleted user in openfire. added same user in openfire and phone mapping.

in sparks, uninstall sip plugin, close and open spark, install sip plugin, close and open spark.

this worked for me. tested on 3 different users. now it is all working.

Do you have any issues with the voice quality? Does it work well for you using SIP Phone Plugin. We have some issues and I would appreciate if you can share some information.

Tried this but got the same ‘Failed to start phone’ message.