powered by Jive Software

Sip Plugin Registration (set port?)

I’m using Openfire 3.6.3 and Asterisk 1.4.21

I’m trying to do a phone mapping and am having no luck getting it to register. When I click Test, the test completes succesfully but it never shows as registered. When I look at my asterisk box, I see the client, but it isn’t registering to port 5060.

How do you specify the port for the client to use? I don’t see it in any config file. I’ve also tried specifying the port at the end of the server address in the settings :5060 with no success. All of my other peers are using 5060 and work fine.

Here is the peer I’m using for Openfire:

  • Name : krismobile
    Secret :
    MD5Secret :
    Context : local
    Subscr.Cont. :
    Language :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    Mailbox :
    VM Extension : asterisk
    LastMsgsSent : 32767/65535
    Call limit : 0
    Dynamic : Yes
    Callerid : “Kris Mobile” <2400>
    MaxCallBR : 384 kbps
    Expire : 682
    Insecure : no
    Nat : RFC3581
    ACL : No
    T38 pt UDPTL : No
    CanReinvite : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Trust RPID : No
    Send RPID : No
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    LastMsg : 0
    ToHost :
    Addr->IP : 192.168.30.104 Port 26448
    Defaddr->IP : 0.0.0.0 Port 5060
    Def. Username: krismobile
    SIP Options : (none)
    Codecs : 0x6 (gsm|ulaw)
    Codec Order : (ulaw:20,gsm:20)
    Auto-Framing: No
    Status : Unmonitored
    Useragent : SIPark
    Reg. Contact : sip:krismobile@192.168.30.104:26448

Edit:

I turned on Sip debug and ran the Test again:

SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.30.104:37622;branch=z9hG4bK9daac459445e5a5186d5cfe5e14e2b91;received=19 2.168.30.104;rport=37622
From: “krismobile” sip:krismobile@192.168.30.104:37622;transport=udp;tag=14712093
To: “krismobile” sip:krismobile@192.168.30.104:37622;transport=udp;tag=as6d9863cd
Call-ID: b6f830372e69aae361e761ff736da76d@192.168.30.104
CSeq: 2 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
WWW-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce="1c452a34"
Content-Length: 0


I didn’t realize it was looking for md5 (i use plaintext in my sip.conf), so I generated the md5 and now use md5secret in the sip.conf. However, I’m still unable to get it to authorize. Where do I define the port?