powered by Jive Software

Slackware VPS

I’'m having trouble getting Openfire to run on a Slackware VPS.

I’‘m new to Slackware (and linux in general, for the most part) but here’'s the score so far:

I created a user “jive” and added it to the group “jive” and gave it the home directory /opt/openfire.

I downloaded and unzipped Java from Java’‘s website. Trying to run openfire as “jive” with ‘’/opt/openfire start’’ returns


No suitable Java Virtual Machine could be found on your system.

The version of the JVM must be at least 1.5.

Please define INSTALL4J_JAVA_HOME to point to a suitable JVM.

You can also try to delete the JVM cache file /opt/openfire/.install4j


How do I tell what Java’‘s home directory is? As I didn’'t know, I ran a few searches on the forum for people having similar problems, and someone suggested trying this from /opt/openfire/lib/:


java -server -jar /opt/openfire/lib/startup.jar


returns


Admin console listening at http://127.0.0.1:9090

Openfire 3.3.1


which looks like a successful start up.

However, as I only have console access to this box, it would be much nicer to configure it remotely via HTTP, and trying to connect to http://:9090 doesn’'t connect to the admin panel. In fact,


netstat -an|grep 9090


returns nothing.

Any ideas?

If “java -version” works, try “which java” to see the path and put that in the script. For example, mine reads “JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun/jre” (Debian).

If the server started and exited right after (what it looks like in your case), check the log files.

2007.05.15 16:49:21 org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlugi n.java:143) Could not start admin conosle server

java.io.IOException: Function not implemented

at sun.nio.ch.EPollArrayWrapper.epollCreate(Native Method)

at sun.nio.ch.EPollArrayWrapper.(SelectorManager.java:205)

at org.mortbay.io.nio.SelectorManager.doStart(SelectorManager.java:113)

at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)

at org.mortbay.jetty.nio.SelectChannelConnector.doStart(SelectChannelConnector.jav a:232)

at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)

at org.mortbay.jetty.Server.doStart(Server.java:221)

at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)

at org.jivesoftware.openfire.container.AdminConsolePlugin.startup(AdminConsolePlug in.java:140)

at org.jivesoftware.openfire.container.AdminConsolePlugin.initializePlugin(AdminCo nsolePlugin.java:175)

at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java :404)

at org.jivesoftware.openfire.container.PluginManager.access$200(PluginManager.java :46)

at org.jivesoftware.openfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:916)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Hi,

what’‘s the output of “java -version”? If it’'s not a Sun JRE you may encounter some problems.

LG

jive@Jabber:~/openfire/logs$ java -version

java version “1.6.0_01”

Java™ SE Runtime Environment (build 1.6.0_01-b06)

Java HotSpot™ Client VM (build 1.6.0_01-b06, mixed mode, sharing)


I reinstalled java - properly, this time - and now bin/openfire start starts it fine, but I get the same error in error.log. java.io.IOException: Function not implemented.

Hi,

take a look at http://www.squid-cache.org/mail-archive/squid-users/200608/index.html#282 and http://www.squid-cache.org/mail-archive/squid-users/200608/0296.html - “Sounds to me that you have no support for epoll in your kernel … unimplemented syscall, so your kernel does not have support for this syscall while your libc do”

LG

I know enough about linux to comprehend what the problem is, at least vaguely, but not enough to know how to fix it. Any suggestions?

Like Marco Berizzi wrote, config.gz is not present on my VPS on /proc/ or anywhere else.

Hi,

also I have no idea how to fix it.

A Slackware mailing list or forum may be the much better place to ask this question.

LG

Same error here. Got epoll in kernel, other software is using it.

Any other idea?