powered by Jive Software

Slow authentication

Hey guys,

I am having a problem with a new Wildfire 2.5.0 install on Windows 2000 Server. I have it setup to use LDAP against a Novell eDirectory.

Last time I visited setting up IM in our enterprise I had Jive Instant Messenger working fine but couldn’‘t find a suitable client for use with it at the time. Now Spark is there and will do what I want but, I can’'t get the now-called Wildfire to work properly. When you go to login using Spark it takes a minute or two to authenticate, then eventually logs in. I have tried using the Soapbox client and this doesnt work at all (suspect it has a lower time-out).

Interestingly I can login to the Wildfire management console perfectly with no delays, which I guess would mean that requires it going to LDAP directory to check for a valid user/pass.

Here is the logfile output. I don’‘t understand XML so hopefully one of you guys will be able to decipher what is happening It looks to me like it can’'t talk properly to its own database - not the LDAP one.

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

2006.03.01 19:17:09 [org.jivesoftware.database.EmbeddedConnectionProvider.getConnection(EmbeddedCon nectionProvider.java:48)

] Error: EmbeddedConnectionProvider.getConnection() wascalled before the internal pool has been initialized.

2006.03.01 19:17:09 [org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManage r.java:116)

] WARNING: ConnectionManager.getConnection() failed to obtain a connection.

2006.03.01 19:17:09 [org.jivesoftware.wildfire.XMPPServer.verifyDataSource(XMPPServer.java:581)

] Database could not be accessed

java.lang.NullPointerException

at org.jivesoftware.wildfire.XMPPServer.verifyDataSource(XMPPServer.java:571)

at org.jivesoftware.wildfire.XMPPServer.start(XMPPServer.java:340)

at org.jivesoftware.wildfire.XMPPServer.(XMPPServer.java:135)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(ServerStarter.java:88)

at org.jivesoftware.wildfire.starter.ServerStarter.main(ServerStarter.java:49)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

Caused by: java.lang.NullPointerException

at org.jivesoftware.wildfire.XMPPServer.verifyDataSource(XMPPServer.java:571)

… 16 more

Welcome John,

fyi this is not XML. It’'s a stacktrace which gives some useful information.

EmbeddedConnectionProvider … Database could not be accessed[/i]

You are using the embedded database but it “could not be accessed”. Does the user which is running Wifi has access to %programfiles%\Wildfire\embedded-db\ ? There you should find the database files, do you see two or four files?

LG

Thanks for your assistamce.

I have checked NTFS permissions of the directory where the database is, and set the Everyone group to have full control. Still no go, though.

Any other ideas at all? Would you like to see my config.xml file?

Thanks, John.

Still haven’'t got this sorted guys.

Do you think it would be worth my while to try setting up an external database? If so, which one would you reccommend for my purposes (running LDAP against Novell eDirectory).

Cheers, John

Can you post your wildfire.xml to look at. I had a real hard tmie authenticating against eDirectory, but with the help of some ofthese good folks I got it working. I have it working on mine now, Linux, going against LDAP in Novell.

Jeff