powered by Jive Software

Slowness on the network by spark

hello
someone could help me, I noticed long delays in the network, and now that I am monitoring, it is for many queries to mysql, and the only thing I have with mysql is the spark.
You can do something about it?

Spark is not doing any sql queries. Maybe you ment Openfire (server)? Well, it should do as many sql connections as needed. How many users do you have?

Hi, thanks for answering,
I have a 83 users of spark, and I have made a network monitoring and tells me that the traffic is mainly due to use port 5222 which is the spark

I could do about it? help please

5222 port is the Openfire (a server) port which Spark is connecting to. I can’t think of any reason for Spark to make too many “connections” or big traffic through this port. Maybe some of your users are sending huge files, or something. It shouldn’t take much traffic just for chatting.

if I disable the option to send files to see if it was, but still just as slow network, I was thinking that was the version of openfire, I have 3.4.6, and from what I have said has some bugs, you think that may be?

thank you!!!

I don’t think there were any bugs related to big network traffic in Openfire or Spark. Not sure what is happening in your network. By the way, how do you monitor and see those many sql connections?

I did a network analysis and shows that it consumes more bandwidth is port 5222, so I thought it was the spark, and the mysql connections, I thought it was related because I have installed munin on my server and tells me that there are many connections to mysql but I’ve read that this is a failure of munin.
I’m going to do is update the version of openfire because I have the 3.4.6 to 3.7.1. you think is good?

thank you very much

Well, there were some issue fixed since 3.4.6, but nothing groundbreaking. Also, there are some new issues with 3.7.1:) Like:

Openfire up to and including version 3.6.4 (and looks like 3.7.0 too) suffers from a memory leak in its PEP component. If your Openfire server is crashing with OutOfMemoryExceptions, you might be having this problem.

As a workaround, you can disable PEP, by setting the Openfire property xmpp.pep.enabled to false.