powered by Jive Software

Smack 2.0.0 Fedora Core 2 and 3

We are using smack 2.0.0 in our application but we need to launch it using linux (Fedora Core 2 and 3) . We already tested our apps with windows and it is working just fine. We then tried running the same program to our linux box when logging in to Google talk using GoogleTalkConnection Class we got this error:

java.lang.ClassCastException: org.jivesoftware.smack.PacketReader$4

at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java: 175)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:352)

at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:318)

We tried installing cyrus sasl and perl sasl and still get the same error. Do we need to do extra tweaking to make this work??

Hey Ramil,

There is no need to install cyrus sasl, perl sasl or any other SASL software. Currently, Smack only supports PLAIN SASL and the support is built in. The ClassCastException that you are having is because the smack.providers file cannot be located. If you are building your own jar files then make sure that the META-INF folder is in your class that. The META-INF folder is where the smack.providers file is located.

Regards,

– Gato

Thanks a bunch it worked just fine.