Smack 3.2.1 - changePassword() issue

Hi there,

I am developiong a chat application using SMACK 3.2.1 as the back end basis. I have recently found an issue when changeing an account’s password, but it only appeared after a specified change was made.

First I used to login with any user by simply providing the username & password of that specified account. As later on I tried to change the password of that account, it was being changed successfully.

Then a few days later I wanted to upgrade the login for my chat system. I wanted the application to allow a single user being logged at the same time from different location. I enabled this by generating a resourceName and passing it as a parameter when calling the XMPPConnection.login(username, password, resource). the logging of different users at the same time in different locations worked successfully.

After this change I tried to change the password of that specified user but a mysterious exception was being thrown. As I was calling the accountmanager.changePassword(newPassword) the below exception was being thrown :

No response from server.:

at org.jivesoftware.smack.AccountManager.changePassword(


at ord(

at com.connexo.icubeplus.web.actions.settings.ChangePasswordAction.execute(ChangeP

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.ja va:25)

at java.lang.reflect.Method.invoke(

at com.opensymphony.xwork2.DefaultActionInvocation.invokeAction(DefaultActionInvoc

at com.opensymphony.xwork2.DefaultActionInvocation.invokeActionOnly(DefaultActionI

at com.opensymphony.xwork2.DefaultActionInvocation.invoke(DefaultActionInvocation. java:254)

at com.opensymphony.xwork2.interceptor.DefaultWorkflowInterceptor.doIntercept(Defa

at com.opensymphony.xwork2.interceptor.MethodFilterInterceptor.intercept(MethodFil

at com.opensymphony.xwork2.DefaultActionInvocation.invoke(DefaultActionInvocation. java:248)

at com.opensymphony.xwork2.validator.ValidationInterceptor.doIntercept(ValidationI

I could not find the solution to this and was suspecting that this is a bug or maybe I am not using the changePassword correctly as it was intended. All credentials are correct as I checked them more than once and with more than one user.

I would really appreciate any help or information regarding my problem.



Run with the debugger enabled and check for any response packets at all. It appears that the server is simply not responding to your request and it is timing out.

Is it possible that there is another exception occurring somewhere when the response is received (in a provider). If you run with the debugger enabled you can view the raw packets which will show if you are actually getting a response or not.

If there is no response, your problem lies with the server.