powered by Jive Software

Smack on Java 1.4 problem

Hello,

I have a Web Application that connects with openfire, it must be deployed on a tomcat app server running java 1.4.

The current version of Spark is not compatible with java 1.4.

First i tryed to backport smack, but to many errors and problems for the few time i have.

In a Smack jabber client(JBother) i found a java 1.4 version of Smack and add that to my WebApp.

I had to remove the connect() method call of XMPPConnection as the version i had did not have that

Now i cannot loggin: (401)

at org.jivesoftware.smack.NonSASLAuthentication.authenticate(NonSASLAuthentication .java:94)
at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java: 223)
at org.jivesoftware.smack.XMPPConnection.login(XMPPConnection.java:410)

I can see the connection being created in openfire on a SessionEventListener!

fires SessionCreated and ResourceBound events

any idea or alternative for Java 1.4 openfire connection?

Tx!