[solved] Problems with s2s connection to GTalk


I’ve been using OpenFire for some time and I’ve recently run into some trouble with connecting to GTalk. My OF was communicating with OF just fine but a few days ago, I restarted the server (trying to resolve unrelated s2s issue) and the server went sort-of haywire.

First, administration told me that my RSA keys are invalid and that I need to re-generate certificates, which I did through web administration (I am using self-signed certificates). Everything seems to work just fine, however my server stopped working with GTalk - other services work OK (jabber.cz, jabber.org, freenet.de, root.cz…).

I’ve Googled a lot and found some usual suspects, which I all checked:

  1. Setting “Optional” in Security Settings -> s2s
  2. Allowing accepting self-signed certificates
  3. Turning off the GTalk service on Google Apps for my domain.
    In fact, these issues were all already dealt with prior to restart.

In order to deal with the problem, I’ve tried to add DNS SRV record for my domain (I didn’t have one before and it worked, so I didn’t bother), which looks like this:
_xmpp-server._tcp. 1800 IN SRV 5 0 5269
,but that didn’t help either.

While error log didn’t offer anything, debug log was a bit more verbose in this matter:
Please note, that domains and users were replaced with <> tokens (, and so on).

Thanks for any help with this problem in advance.


I am bumping this thread - I am still having this issue and I am not exactly sure how to proceed. If anyone could point me in the right direction, I would very much appreciate it.

Found the source of the problem (but not the cause).

Notice this log message:

2010.11.24 16:10:57 ServerDialback: RS - Trying to connect to Authoritative Server: gmail.com:5269(DNS lookup: gmail.com:5269)

Then compare it to a message from log of my friend’s server:

trying to connect to remote server: gmail.com(DNS lookup: xmpp-server2.l.google.com:5269)

I was using my own DNS server (BIND), so I switched to OpenDNS and everything works fine (GTalk and Google Apps accounts slowly went online).

I checked my BIND configuration and everything seems to be fine (it wasn’t altered in any way prior to my problem occuring), so I have no idea where the problem was.

However, this problem is solved.