Spark 2.0.0 Online Installer fails for me


the installer fails as it tries to use an 1.4 JRE during installation process. As I have JRE and JDK 1.5 installed I wonder how I can select it so Spark will use it.

The error log contains


java.lang.UnsupportedClassVersionError: org/jivesoftware/Installer (Unsupported major.minor version 49.0)

at java.lang.ClassLoader.defineClass0(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at Source)

at Source)

at$100(Unknown Source)

at$ Source)

at Method)

at Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at com.install4j.runtime.installer.InstallerUtil.newUserInstance(Unknown Source)

at com.install4j.runtime.installer.InstallerUtil.instantiateClass(Unknown Source)

at com.install4j.runtime.installer.InstallerUtil.instantiateAction(Unknown Source)

at com.install4j.runtime.installer.Installer.doInstallation(Unknown Source)

at com.install4j.runtime.installer.Installer.install(Unknown Source)

at com.install4j.runtime.installer.frontend.screens.InstallationScreen$ wn Source)



and a lot of sensitive information I don’'t want to post here.

I can not uninstall JRE 1.4.2.


I had the exact same problem. I managed to get the 2.0.0 version installed by actually deleting the Spark directory under the Program Files directory (the Spark directory was empty after I tried updating the software from within the program itself by clicking ‘‘Yes’’ to the ‘‘Do you want to download the latest version’’ prompt). Anyway, after deleting the Spark directory and downloading and installing the 2.0.0 installer, everything worked fine.

Downside was that my chat histories are now gone, but, oh well.

Looks like the installer needs a change to the minimum JRE of 1.5. Will file and fix immediatly.