Spark 2.0 Beta 3 Released

We are pleased to announce the release of Spark 2.0 Beta 3. This build contains mainly bug fixes and polish work as well as XMPP URI support. Let us know how it goes.



): once again a beta with JRE. So it goes nowhere for me, just to let you know. Once upon a time there was the idea to release just new jars and libs as a diff / patch for Spark and Wildfire but it seems that the idea did choose the wrong way, turned somewhere left and did hit a dead end.

…original post deleted… Found answer in other thread…

Message was edited by: scottwilkins

Still non-functional on my AMD laptop. The login screen appears fine, but after I log on, Spark exits. Nothing in the Spark error.log, but a new text file is created in the Spark directory, called hs_err_pid1928.log, containing the following (apologies for long post):

  1. An unexpected error has been detected by HotSpot Virtual Machine:

  1. EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d6d8329, pid=1928, tid=1888

  1. Java VM: Java HotSpot™ Client VM (1.5.0_05-b05 mixed mode, sharing)

  2. Problematic frame:

  3. V

T H R E A D -

Current thread (0x009b8b60): JavaThread “Thread-11” daemon

siginfo: ExceptionCode=0xc0000005, reading address 0x00000000


EAX=0x00000000, EBX=0x00004076, ECX=0x06dbf02c, EDX=0x00000000

ESP=0x06dbf00c, EBP=0x06dbf058, ESI=0x06dbf02c, EDI=0x00000000

EIP=0x6d6d8329, EFLAGS=0x00010246

Top of Stack: (sp=0x06dbf00c)

0x06dbf00c: 6d6c69d5 00000000 009b8b60 6d6c98ff

0x06dbf01c: 009b8b60 00000000 06dbf080 00000001

0x06dbf02c: 00000000 00000000 00000000 00000000

0x06dbf03c: 00000000 00000000 00000000 0000000e

0x06dbf04c: 00000000 00000000 00000000 00000000

0x06dbf05c: 05a21cdc 009b8c1c 00000000 00000000

0x06dbf06c: 06dbf080 05a212c1 009b8c1c 00000000

0x06dbf07c: 00000000 00004076 00000000 00000340

Instructions: (pc=0x6d6d8329)

0x6d6d8319: 44 24 04 24 fc 8b 00 8b 00 c3 8b 44 24 04 24 fc

0x6d6d8329: 8b 00 ff 74 24 04 8b c8 e8 93 fe ff ff c3 8b 44

Stack: [0x06bc0000,0x06dc0000), sp=0x06dbf00c, free space=2044k

Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)


Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)

j org.jdesktop.jdic.tray.internal.impl.DisplayThread.initTray()V+0


v ~StubRoutines::call_stub

P R O C E S S -

Java Threads: ( => current thread )

=>0x009b8b60 JavaThread “Thread-11” daemon

0x009b8100 JavaThread “Timer-1”

0x009af200 JavaThread “Timer-0”

0x009b6620 JavaThread “Thread-7” daemon

0x009b1e00 JavaThread “Smack Listener Processor” daemon

0x009b1900 JavaThread “Smack Packet Reader” daemon

0x009b1590 JavaThread “Smack Packet Writer” daemon

0x009a9e80 JavaThread “Image Fetcher 3” daemon

0x009a9770 JavaThread “Image Fetcher 2” daemon

0x009a9100 JavaThread “Image Fetcher 1” daemon

0x009a8680 JavaThread “Image Fetcher 0” daemon

0x00999dc0 JavaThread “Thread-3” daemon

0x009a6740 JavaThread “Thread-2”

0x00997720 JavaThread “TimerQueue” daemon

0x00993100 JavaThread “AWT-EventQueue-0”

0x00992900 JavaThread “AWT-Shutdown”

0x009892e0 JavaThread “Java2D Disposer” daemon

0x00986640 JavaThread “AWT-Windows” daemon

0x00980860 JavaThread “Exe4JStartupThread” daemon

0x0097d530 JavaThread “Low Memory Detector” daemon

0x0097c350 JavaThread “CompilerThread0” daemon

0x0097c9f0 JavaThread “Signal Dispatcher” daemon

0x0097b640 JavaThread “Finalizer” daemon

0x0097b100 JavaThread “Reference Handler” daemon

0x00973820 JavaThread “main”

Other Threads:

0x0097a6d0 VMThread

0x0097e200 WatcherThread

VM state:not at safepoint (normal execution)

VM Mutex/Monitor currently owned by a thread: None


def new generation total 1152K, used 946K [0x24010000, 0x24140000, 0x244f0000)

eden space 1088K, 81% used [0x24010000, 0x240eca10, 0x24120000)

from space 64K, 100% used [0x24130000, 0x24140000, 0x24140000)

to space 64K, 0% used [0x24120000, 0x24120000, 0x24130000)

tenured generation total 15168K, used 4936K [0x244f0000, 0x253c0000, 0x28010000)

the space 15168K, 32% used [0x244f0000, 0x249c2388, 0x249c2400, 0x253c0000)

compacting perm gen total 12288K, used 4014K [0x28010000, 0x28c10000, 0x2c010000)

the space 12288K, 32% used [0x28010000, 0x283fb9a8, 0x283fba00, 0x28c10000)

ro space 8192K, 62% used [0x2c010000, 0x2c51a3a0, 0x2c51a400, 0x2c810000)

rw space 12288K, 46% used [0x2c810000, 0x2cda03d8, 0x2cda0400, 0x2d410000)

Dynamic libraries:

0x00400000 - 0x00438000 C:\Program Files\Spark\Spark.exe

0x7c900000 - 0x7c9b0000 C:\WINDOWS\system32\ntdll.dll

0x7c800000 - 0x7c8f4000 C:\WINDOWS\system32\kernel32.dll

0x77dd0000 - 0x77e6b000 C:\WINDOWS\system32\ADVAPI32.DLL

0x77e70000 - 0x77f01000 C:\WINDOWS\system32\RPCRT4.dll

0x77f10000 - 0x77f57000 C:\WINDOWS\system32\GDI32.dll

0x77d40000 - 0x77dd0000 C:\WINDOWS\system32\USER32.dll

0x77c10000 - 0x77c68000 C:\WINDOWS\system32\msvcrt.dll

0x7c9c0000 - 0x7d1d5000 C:\WINDOWS\system32\SHELL32.DLL

0x77f60000 - 0x77fd6000 C:\WINDOWS\system32\SHLWAPI.dll

0x629c0000 - 0x629c9000 C:\WINDOWS\system32\LPK.DLL

0x74d90000 - 0x74dfb000 C:\WINDOWS\system32\USP10.dll

0x10000000 - 0x10007000 C:\WINDOWS\system32\ASAPHook.dll

0x773d0000 - 0x774d2000 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6 .0.2600.2180_x-ww_a84f1ff9\comctl32.dll

0x5d090000 - 0x5d127000 C:\WINDOWS\system32\comctl32.dll

0x77b40000 - 0x77b62000 C:\WINDOWS\system32\Apphelp.dll

0x6d640000 - 0x6d7cc000 c:\progra~1\spark\jre\bin\client\jvm.dll

0x76b40000 - 0x76b6d000 C:\WINDOWS\system32\WINMM.dll

0x6d280000 - 0x6d288000 c:\progra~1\spark\jre\bin\hpi.dll

0x76bf0000 - 0x76bfb000 C:\WINDOWS\system32\PSAPI.DLL

0x6d610000 - 0x6d61c000 c:\progra~1\spark\jre\bin\verify.dll

0x6d300000 - 0x6d31d000 c:\progra~1\spark\jre\bin\java.dll

0x6d630000 - 0x6d63f000 c:\progra~1\spark\jre\bin\zip.dll

0x6d000000 - 0x6d167000 C:\Program Files\Spark\jre\bin\awt.dll

0x73000000 - 0x73026000 C:\WINDOWS\system32\WINSPOOL.DRV

0x76390000 - 0x763ad000 C:\WINDOWS\system32\IMM32.dll

0x774e0000 - 0x7761d000 C:\WINDOWS\system32\ole32.dll

0x5ad70000 - 0x5ada8000 C:\WINDOWS\system32\uxtheme.dll

0x74720000 - 0x7476b000 C:\WINDOWS\system32\MSCTF.dll

0x01570000 - 0x01579000 C:\Program Files\HPQ\IAM\Bin\ItClient.dll

0x7c000000 - 0x7c054000 C:\WINDOWS\system32\MSVCR70.dll

0x6d240000 - 0x6d27d000 C:\Program Files\Spark\jre\bin\fontmanager.dll

0x6d4c0000 - 0x6d4d3000 C:\Program Files\Spark\jre\bin\net.dll

0x71ab0000 - 0x71ac7000 C:\WINDOWS\system32\WS2_32.dll

0x71aa0000 - 0x71aa8000 C:\WINDOWS\system32\WS2HELP.dll

0x6d4e0000 - 0x6d4e9000 C:\Program Files\Spark\jre\bin\nio.dll

0x71a50000 - 0x71a8f000 C:\WINDOWS\System32\mswsock.dll

0x76f20000 - 0x76f47000 C:\WINDOWS\system32\DNSAPI.dll

0x76fb0000 - 0x76fb8000 C:\WINDOWS\System32\winrnr.dll

0x76f60000 - 0x76f8c000 C:\WINDOWS\system32\WLDAP32.dll

0x76fc0000 - 0x76fc6000 C:\WINDOWS\system32\rasadhlp.dll

0x76d60000 - 0x76d79000 C:\WINDOWS\system32\iphlpapi.dll

0x662b0000 - 0x66308000 C:\WINDOWS\system32\hnetcfg.dll

0x71a90000 - 0x71a98000 C:\WINDOWS\System32\wshtcpip.dll

0x6d1c0000 - 0x6d1e3000 C:\Program Files\Spark\jre\bin\dcpr.dll

0x605d0000 - 0x605d9000 C:\WINDOWS\system32\mslbui.dll

0x77120000 - 0x771ac000 C:\WINDOWS\system32\OLEAUT32.DLL

0x0ffd0000 - 0x0fff8000 C:\WINDOWS\system32\rsaenh.dll

0x769c0000 - 0x76a73000 C:\WINDOWS\system32\USERENV.dll

0x5b860000 - 0x5b8b4000 C:\WINDOWS\system32\netapi32.dll

0x05a20000 - 0x05a2b000 C:\Program Files\Spark\lib\windows\tray.dll

VM Arguments:

jvm_args: -Dexe4j.semaphoreName=c:_progra1_spark_spark.exe -Dexe4j.isInstall4j=true -Dexe4j.moduleName=c:\progra1\spark\spark.exe -Dexe4j.processCommFile=C:\DOCUME1\tchadwin\LOCALS1\Temp\e4j_p1928.tmp -Dexe4j.tempDir= -Dappdir=c:\progra~1\spark\ -Xms16m -XX:PermSize=12m -Dsun.java2d.noddraw=true


Environment Variables:

CLASSPATH=C:\Program Files\Java\jre1.5.0_06\lib\ext\

PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\ATI Technologies\ATI Control Panel;C:\Program Files\HPQ\IAM\bin;C:\PROGRA1\CA\SHARED1\SCANEN1;C:\PROGRA1\CA\ETRUST~1;C:\Program Files\QuickTime\QTSystem;C:\Program Files\Microsoft SQL Server\80\Tools\Binn;C:\Program Files\Common Files\Adobe\AGL



PROCESSOR_IDENTIFIER=x86 Family 15 Model 36 Stepping 2, AuthenticAMD

S Y S T E M -

OS: Windows XP Build 2600 Service Pack 2

CPU:total 1 family 47, cmov, cx8, fxsr, mmx, sse, sse2

Memory: 4k page, physical 916848k(319620k free), swap 1433672k(895708k free)

vm_info: Java HotSpot™ Client VM (1.5.0_05-b05) for windows-x86, built on Aug 26 2005 15:36:02 by “java_re” with MS VC++ 6.0

Hope this helps.


Message was edited by: tomchadwin

Just installed this on Linux, and the preferences dialog doesn’‘t work. When you click Spark, Preferences, the dialog appears but the icons on the left arn’‘t visisble unless I stretch the dialog box out a bit. Then clicking any of those icons doesn’‘t do anything, nothing in the main window changes to show the options. The close button doesn’'t even work, I have to press the X to close the dialog.



Oh and the status message that says the other user is typing a message flickers on and off so it’'s difficult to see it.

Love the product, and have had no major issues. There is one quirk however, that I was hoping might be very easy to implement. I wasn’‘t entirely sure where to put feature requests and I didn’'t find an existing one in the developer section, so I thought I might take a change here.

I deal with word processing all day, and use keyboard shortcuts all the time. Specifically, on windows if you hold the control key when using the cursor keys, you can move left and right over entire words at a time rather than one character at a time. If you hold control when using backspace it deletes the entire word rather than one character at a time. While the controlcursor keys work correctly in spark while typing messages, the controlbackspace doesn’'t work (it does actually work in this forum but is probably a browser feature). Instead, what I have to do is hold controlshiftcursor_left to highlight the word and then delete it.

As I said, a small quirk, but it catches me every time. Where might I make the query to have this small functionality implemented?



I was thinking about your problems… What is “HotSpot Virtual Machine”? Is that another java VM you might have installed? Try to remove that VM and install the Sun VM from and see if you can run Spark with no problems.



HotSpot™ is SUN’'s JVM, today version 1.5.0_08 is the current one so _05 is rather old. Using the newest one could indeed help to fix this problem.


Hi both

Funny you should both reply today, as I was having similar thoughts. I uninstalled Spark, and then uninstalled both versions of Java I could see in Add/remove programs (though both claimed to be “updates” as I remember).

I have not installed any JRE other than whatever is bundled with the beta3 executable, and then reinstalled Spark. Same error, but still with the line:

Java VM: Java HotSpot™ Client VM (1.5.0_05-b05 mixed mode, sharing)

So I presume I have failed fully to uninstall Java. Given that I have removed the two entries I could find in Add/remove programs, where else do I look for installations?

Is it worth my downloading the JRE from Sun despite the fact that the exe has a bundled JRE? How does it choose which to use.

Thanks for all the help, and apologies for so many ignorant questions.




I did not install one of the betas as I have already the JDK installed and I don’‘t want to have another JRE on my system - so I don’'t know which one is bundled with Spark. “wroot” did point out that it is possible to delete the Spark-JRE after installation of the beta, Spark.exe will then search for another installed JVM.

So installing the current JRE and deleting the one Spark installs could help.

I did not look at the date of the JRE until Scott did mention that you could be using the wrong JRE, so you got the two replies - and the Tray-Icon is problematic as it uses DLL’‘s. I’‘d love to see a Java-Only version without DLL’'s.


Reinstalled Spark, and confirmed same crash and error still occur. Deleted the jre folder in the Spark installation directory. Spark then gave an error on start-up, saying it could not find a JVM on my system, and that I needed to set the appropriate environment variable.

Hope this helps (me and Spark…)

Thanks again



did you install the current JRE from If Spark fails to find it you may copy it to the location where Spark did install its own JRE.


Just tried installing Sun’‘s JRE. Tried its default location first (c:\program files\java\something), and then uninstalled and tried it in the Spark folder. Both times it presumably found the JRE, since I didn’'t get the “Cannot find JRE” error, but both crashed immediately after authentication, just as before with the packaged JRE, generating the hs_err_pidxxxx.log.

Any more ideas, anyone?

Thanks again



One problem with the binding you mentioned ctrlbackspace is that happens to be one key off restarting X11 (altctl+backspace). This may not be a problem at all but it may be something worth taking into account.

Regarding other keybindings shift+insert should paste (and it does not). Some compound sequences do not work such as “^~`” + <space> should give a ^ (on fr_CH layout), actually none of the 3 symbols from that keyboard key work in the Spark input box. Slightly related but not necessarily, some text pasted gets “transformed”. This seems to involve quotes and double quotes getting chopped off. I notice it when pasting long bash commands, sql queries or bits of sourcecode to someone over Spark.

As soon as a newer version is released which isn’'t bundled with a VM I will do some further testing to see if any of these annoyances have gone away.

Cheers, RioGD

Post Scriptum: Some or all of these problems could be a problem with java and not Spark specifically, I don’'t really know. This is what I am running in case it helps:

  1. java-config -L

*) Sun JDK (/usr/share/java-config-2/vm/sun-jdk-1.5)

  1. Sun JRE (/usr/share/java-config-2/vm/sun-jre-bin-1.5)

(hmmm in the forum wrapping anything in between square brackets seems to turn it into a link… in the above, it should be sun-jdk-1.5 and sun-jre-bin-1.5 between square brackets. And by themselves it turned into http://] when I first wrote this small clarification )

Hi Tom,

cyclone had the idea to move the whole SysTray code into a plugin. Spark will not be so fine without SysTray support but is should a least work if it get’'s implemented. Please vote for SPARK-373 if you like such a solution.