powered by Jive Software

Spark 2.5.0: MSI upgrade, need to uninstall previous version

Is it a feature or what? Why should i uninstall every previous version (now it 2.5.0 Beta 4) to be able to upgrade?

Paint.NET setup is automaticly removing old installation and installs new one. I mean if i upgrade say 3.01 to 3.05 i only specify common settings (path, start menu, desktop shortcuts, update checking). When i press last OK, it removes old/copies new. Well, it should be two MSI combined in one package, but maybe it’'s possible to combine two MS in one MSI.

Ok Wroot. So what is the deal with this? You just cannot for whatever reason install over the old one? Let me see if the MSI package I use has an auto-uninstall on install.

Thanks,

Derek

I also had to uninstall my 2.5b4 before it would let me install 2.5

Also… the first install didn’'t install the whole program. After the uninstall of 2.5b4 it left a logs, plugins, and jre folder.

When I ran the 2.5msi file it “upgraded” what files where there but didn’‘t install everything I had to run the MSI again and click modify then choose to install all files to disk. Kinda weird and I’'m a little scared to push this file out over our network yet.

tdickson wrote:

Also… the first install didn’'t install the whole program. After the uninstall of 2.5b4 it left a logs, plugins, and jre folder.

When I ran the 2.5msi file it “upgraded” what files where there but didn’‘t install everything I had to run the MSI again and click modify then choose to install all files to disk. Kinda weird and I’'m a little scared to push this file out over our network yet.

so it sounds even worse than i thought, maybe this is the reason for the other problems with MSI (missing Jingle)

http://www.igniterealtime.org/forum/thread.jspa?threadID=25584&tstart=0

ddman wrote:

Ok Wroot. So what is the deal with this? You just cannot for whatever reason install over the old one?

The reason is that your MSI installer says that there is another version already installed and that i must uninstall it first. We will probably need to push MSI installs through AD, so i need it to be less complicated. I dont want to upgrade all 170 users manually. Though i’'m not yet familiar about how our AD works, it;s a new thing to us. Maybe there are some other ways to make upgrade process less painful.

as upgrading from 2.5.0 MSI online to 2.5.1 MSI online went fine (without teling me to uninstall previous version), so it seems to be fixed. Thanks

Glad to hear it

Derek