powered by Jive Software

Spark 2.5.5 connected to Wildfire Server but cant message anyone - Vista

New PC. Vista Business. All Patched up. ZoneAlarm Security Suite installed. Suspect firewall type issue for first issue?

2 Issues:

  1. Spark 2.5.5 connects to its Wildfire Server across the Internet. Says its live. Can search and add users from Wildfire Server. Users have been added to Spark.

Unable to message any users at all - even the local ones on the LAN.

Messages being sent do not come back with any errors. Broadcasts do not come back with any errors.

  1. When I click on Spark - nothing happens. In order to get it to run I have to right click the icon and run as administrator? (Oh, I was logged on as Administrator anyway).

Help!

Thx

Hi david, welcome to Ignite Realtime community B-).

Once you can connect, it’s no longer a firewall issue.

  1. I’m suspecting some naming problem here, but probably not. You might want to turn on Spark debug option to see what’s being sent/received. Also click Help::View Logs and see if there’s any problem.

  2. Spark doesn’t require you to run with admin priviledge. Do you find any clue in \Spark\logs?

Info from log file pasted below. I have no idea what it is saying. Rgds, & Thx, Dave

22/08/2007 09:22:32 org.jivesoftware.spark.util.log.Log error

SEVERE: Connection closed on error.

java.net.SocketException: socket closed

        at java.net.SocketInputStream.socketRead0(Native Method)

        at java.net.SocketInputStream.read(Unknown Source)

        at com.sun.net.ssl.internal.ssl.InputRecord.readFully(Unknown Source)

        at com.sun.net.ssl.internal.ssl.InputRecord.read(Unknown Source)

        at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(Unknown Source)

        at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readDataRecord(Unknown Source)

        at com.sun.net.ssl.internal.ssl.AppInputStream.read(Unknown Source)

        at sun.nio.cs.StreamDecoder.readBytes(Unknown Source)

        at sun.nio.cs.StreamDecoder.implRead(Unknown Source)

        at sun.nio.cs.StreamDecoder.read(Unknown Source)

        at java.io.InputStreamReader.read(Unknown Source)

        at java.io.BufferedReader.fill(Unknown Source)

        at java.io.BufferedReader.read1(Unknown Source)

        at java.io.BufferedReader.read(Unknown Source)

        at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2971)

        at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

        at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1144)

        at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)

        at org.jivesoftware.smack.PacketReader.parsePackets(PacketReader.java:368)

        at org.jivesoftware.smack.PacketReader.access$000(PacketReader.java:44)

        at org.jivesoftware.smack.PacketReader$1.run(PacketReader.java:76)

22/08/2007 09:22:32 org.jivesoftware.spark.util.log.Log error

SEVERE: Connection closed on error.

java.io.IOException: Stream closed

        at java.io.BufferedWriter.ensureOpen(Unknown Source)

        at java.io.BufferedWriter.write(Unknown Source)

        at java.io.Writer.write(Unknown Source)

        at org.jivesoftware.smack.PacketWriter.writePackets(PacketWriter.java:258)

        at org.jivesoftware.smack.PacketWriter.access$000(PacketWriter.java:40)

        at org.jivesoftware.smack.PacketWriter$1.run(PacketWriter.java:87)

22/08/2007 11:36:42 org.jivesoftware.spark.util.log.Log error

SEVERE:

internal-server-error(500)

        at org.jivesoftware.smackx.packet.VCard.doLoad(VCard.java:536)

        at org.jivesoftware.smackx.packet.VCard.load(VCard.java:507)

        at org.jivesoftware.sparkimpl.profile.VCardManager.getVCard(VCardManager.java:311)

        at org.jivesoftware.spark.ui.status.StatusBar$9.construct(StatusBar.java:365)

        at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:129)

        at java.lang.Thread.run(Unknown Source)

23/08/2007 09:27:52 org.jivesoftware.spark.util.log.Log error

SEVERE:

internal-server-error(500)

        at org.jivesoftware.smackx.packet.VCard.doLoad(VCard.java:536)

        at org.jivesoftware.smackx.packet.VCard.load(VCard.java:507)

        at org.jivesoftware.sparkimpl.profile.VCardManager.getVCard(VCardManager.java:311)

        at org.jivesoftware.spark.ui.status.StatusBar$9.construct(StatusBar.java:365)

        at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:129)

        at java.lang.Thread.run(Unknown Source)

Hi… I still need some help here. I do not know how to interpret the log file (extract in previous message).

Rgds

Dave

Had this happen with several profiles, but not all. I had to uninstall SPARK and delete the spark folder in my user settings (C:
documents and settings\myusername\spark), and then re-install spark.

Many Thx. Will try in the next few days. Site is remote from where I am (about 1000Km remote) so I’ll have to talk someone through it.

Cheers, Dave