powered by Jive Software

Spark 2.5.8 and JVM 1.5.0_11 on W2K SP4

Hi !

I’m going to deploy Spark 2.5.8 on about 200 workstations with OS W2K Sp4 and JVM 1.5.0_11.

And, I’m not allowed to upgrade JVM Version.

So, do you know if Spark support this JVM version ?

Or where can I find Spark’s JVM Support information ?



Use the full spark installer and I think it should work as it comes bundled with JRE in its own folder structure. The only issue may be the JRE’s compatibility to the legacy OS you are running.

If you install the msi version of Spark (the one without the jre), you can edit the spark.ini file to run under the jvm 1.5.

Look for the Minimum Version= entry and set that to 1.5 instead of 1.6.

I haven’t experienced any problems running spark on 1.5 instead of 1.6.

I have a computer log on script that replaces the spark.ini file after the program is installed.

We have JAVA web start program that I am only comfortable running under 1.5 and this also reduces the deploy file size form 42 to 16 megs.

thx, your answer is very usefull !!!