powered by Jive Software

Spark 2.5.8 with openfire 3.4.1 doesnt reconnect

When I get the window “Your connection was closed due to the same user loggin in from another location”, and I hit the reconnect button, it hangs indefinately.

I’m pretty sure this worked with the previous openfire server, so something appears to have changed, since certainly now the older clients exhibit the same behaviour.

Let me know if you need more details…

Sam.

Not sure i’ve ever gotten that to work with Spark 2.5.4-2.5.8b1 and Openfire 3.3.0 thru 3.4.1 now… thought it was just me. lol

Maybe you should report this in Openfire Support forum too. What are the resource policies in your server? Always Kick? Have you tried with other clients? I cant test it right now. Maybe later or tomorrow.

I have tried combinations of policies, and nothing seems to make a difference.

When Spark hangs up, I know it’s frozen on “reconnecting…” If I tell it to Log Out, it logs out, gives the ability to login from the initial login screen again, as if I started a new session.

dm

I cant make Spark freeze on reconnect. Is it freezing for you when it reconnects itself or only when you press Reconnect button? Is server already available in that moment? The only problem i have noticed today is that after server restart Spark didnt show correct roster (some contacts were missing) after reconnect, so i had to log out and login again.

I can get it to consistently do it by logging in on one machine, and then logging in as the same user on a different machine.

Its possible this is an openfire issue, since I get this with all versions of spark connecting to openfire. My conflict policy on the server is set to “Always kick”.

Sam.

When I reconnect, it hangs. It is stuck on the “Attempting…” screen

The tray icon becomes the red flame with the X on it, and the mouseover shows “Spark - Available”

If I check the Web Admin, it shows I am not connected.

Hi,

you may want to vote for SPARK-854.

LG