powered by Jive Software

Spark 2.5 | Jingle (computer to computer) Woes

Hello,

I’‘ve done some testing which has revealed a problem for us: we cannot establish ‘‘computer-to-computer’’ vChats with anyone outside our network (we can using gTalk). When the call is initiated, it’‘s recieved on the other end (direction doesn’‘t seem to matter, tried it both ways). When it’'s answered, the clients try to establish a connection but immediatly hang up. There is no error, persay - it ends as though it thought it was suposed to, saying something to the effect of: ‘‘voice session ended’’. It works fine on our internal network…

Are there ports that need to be opened up through NAT?

Traffic incoming to our office is NAT’‘d twice, is this an issue? Unfortunately, I can’'t test it connecting to our server from 2 seperate SOHO locations (triangle).

Any suggestions to either resolve the issue or provide further information to better understand the problem are highly appreciated.

Thank you and regards,

Which kind of NAT are you using?

Does your NAT provide access to UDP packets? Especially for high ports?

Jingle uses UDP for transport and needs dynamic UDP bind to access external IPs.

Are you running your own XMPP Server? Or are you connected to jivesoftware.com?

Best Regards,

Thiago

We are running into the same problem. Is there a range of UDP ports that we have to allow through our firewall? Are there any additional TCP ports besides the ones we already have open for Spark/Openfire?

Message was edited by: mjalbers

Hi!

Which kind of NAT are you using?

The Linux kernel.2.6 IPTABLES kind, IP masquerading I suppose, and Netgear’'s IOS (something…).

spark – iptables (nat) – internet – iptables (nat) – netgear soho router (nat) – spark

Does your NAT provide access to UDP packets? Especially for high ports?

Yes.

Are you running your own XMPP Server? Or are you connected to jivesoftware.com?

I’‘m running the last version of WildFire (beofre OpenFire) and Spark client 2.5.0. I am not aware that I am running an XMPP server (though I suppose Spark, or WildFire could be), nor am I conciously connecting to jivesoftware.com (I could be though, I suppose). I’'ve a very ‘‘vanilla’’, default configuration.

Where do we stand, what do you suggest we do to move forward?

Regards,

Bump.

You can try change the settings for media proxy settings in openfire.

Try to add a keep alive value bigger than 120 and try again.

Best Regards,

Thiago