Spark 2.6.2 & Login Difficulties

I installed spark 2.6.2 with no issues, but when the client launches under Win7Pro(32) my login and server are populated from my prior install but my saved password is blank, this results in an invalid user/password error. I am unable to edit any box as they are all grayed out. The same thing happens when I run as Admin, also my UAC are turned off.

When I install on a XPPro machine I get the same error, but after I get the error I can edit the information and login. If I close spark and reopen it the information is properly saved again.

All SSO options are disabled and the account is not locked out.

Please delete the profile and create a new one. This seems to be related to a copy error from the profile. We were not able to track this issue down during 2.6. development.

You can only delete the file in your Spark profile.

It seems that Spark is getting confused when it has to encrypt both login and password together and the passsword is already encrypted (this was introduced together with the option to save and select multiple logins).


I noticed your comment about this being introduced with the “Option” to save and select multiple logins. First off, I cannot locate that option anywhere. How can that Option be turned off or disabled. I do not want/need it in our enviornment. Actually it is causing me terrible problems now. We have our users on folder redirection, with the Spark profile/settings locked down, and well as a custom spark.jar file to lock down all the rest of the settings. Basically when a user logs into a domain computer, Spark starts, logged on auto with their username, and using a default “preset” password that we control, with all settings greyed out. This is locked down and cannot be changed by the client. New clients automatically get added into Openfire via http registration, then their properties file is created and setup on the fly. Now with this new feature with the login getting encrypted, we cannot just push out a default properties file, as now the password line looks like this:


it used to look like this:


Is there any way to fix this or disable that feature, I couldn’t seem to find it anywhere? This will wreck my total enviornment if not.

Also,on a lighter note, the new line does not have password=, it just is password… then the encryped credentials right after. Didn’t know if that was by design…


you can use the normal decrypting algorithm located in spark to generate that line

it consists of


bold letters are encrypted**

But how will that help me generate that line for 1000 users on the fly? Basically I have a generic file with options preconfigured. When a new users logs on, or I do and upagrde of spark, they get added into openfire via an http script, then the user gets spark installed, a custom jar file is copied over, and then their preferences folder is generated in the app data location. The file is copied over from the server. Another script runs, checks their logged in username, edits the properties file and fills their name in the required area. The excrypted password is already in the generic properties template. So how can I make my script take their username, and my generic password and generate that whole encrypted line unattended? I guess I don’t understand how I can get to that. Please explain to my in Cliffs Notes version!

Thanks for any assistance you can offer me.


you need to edit your script which edits the properties file

ill provide you with some sample java code to do this:

give this to whoever wrote the script

I see what you are doing, but I don’t do java! I am the one who scripted all of what we are doing. It was all done with VB, batch, and some autoit. Any more cliff notes to help? I was hoping it was going to be an option somewhere to just disable. I appreciate the quick answer though!

In reply to original post, the answer is NOT totally correct, since I could not get my issue really worked out, I blew out my whole server and built a new one with LDAP integration vs a database. I am now seeing EXACTLY the same issue as the top poster in a very specific situation. I believe it is a MAJOR bug that needs addressed as soon as possible. Let me explain… Openfire 3.7.0 NEW, Spark 2.6.2 to all clients NEW, all previous versions and settings blown out. User logs in first time using same AD credentials they use to log onto PC (LDAP). They naturally choose save password, and most choose auto login. They travel to different PC’s and all is good…BUT, as soon as they are prompted to change their password because of Domain Security Policies, everything goes bad. They change their password. Next time they log into their PC and Spark launches, it tries to auto login, which naturally it cannot, as the password stored is now different than AD (LDAP) password. Now it hits the same roadbloack as first post, you are prompted with “invalid username or password” you click out of that, and you CANNOT try to even change your password, it is locked (greyed) out. The only fix, which is NOT a fix, is to blow their properties file out, or change their setting to false for auto login. Sorry I won’t be doing that for 1000+ users anytime soon. Any idea on a fix? It would seem ccorrect operation would be the error, and then be back at the login box, WITH the ability to type in a different password, while still having the rest of the settings stay the same.


Please check the nightly build at

Actually your report was read and we adressed it. Maybe you want to read the announcement and the listed bug fixes. Your issue is the first one listed.