powered by Jive Software

Spark 2.6.3 - Memory and CPU Causing Freezing

We are in testing and I have Spark 2.6.3 installed on 5 machines. After about a week, a few will become unresponsive. Everything on the machine will run fine but if I try to look at Spark, it becomes unresponsive and I the GUI won’t even display. Looking at Task Manager either Spark or Javaw, CPU is some times around 50 and Mem Usage is around 300,000k. To the other users, the user looks fine and online. If you send a message to it, it looks like it goes through but it does not.

I tried creating a Spark.vmoptions but it doesn’t seem to work cause no file is being created. The only way to fix it is to kill the process and open it then everything works fine again. Seems to be a memory leak but it doesn’t seem to happen to every machine. Is this a known problem? Any suggestions on how to fix the problem? Thanks!

What are the specs of those machines which lock up? Spark can be sometimes unresponsive on older low resources machines. You can also try installing the latest nightly build on those machines to see if that helps

http://bamboo.igniterealtime.org/artifact/SPARK-INSTALL4J/JOB1/build-600/Install 4j/spark_2_6_3_12555.exe

They’re all decent machines. Some are test boxes, which are servers. All 64 bit, nothing less than 2.2 GHz, and nothing less than 4 GB of RAM. I’ve also tried new builds with no success unfortunately. Thanks for the suggestions.

Btw, did you mean running about a week without turning Spark off? This could also be a cause if there are memory leaks. I usually run Spark mostly 8 hours per day before turning off my PC, so maybe i just never hit that leak so hard. Do you have avatars setup or maybe send a lot of text or images?

I have one machine that gets rebooted daily cause it’s the machine I use and it never has a problem. It’s the ones that never get rebooted as we have people in our company that leave their PCs on and go weeks without rebooting.

Sounds like a memory leak to me too, just wondering if anyone else knew how to fix it or has experienced it too to confirm it. I do not have avatars and currently nothing is being sent. The Spark clients are on test boxes with no usage. Thanks!

Something similar http://community.igniterealtime.org/message/231867#231867

Though Jason claims it started happening only with the latest builds and a few new patches applied.