powered by Jive Software

Spark 2.6.3. Presence Status not working correctly

While running 2.6.3. Presence information is not being exposed correctly.

Status menu->Set Custom Status. THis status will show to all users correctly.

Presence information when this is done:

I am not here!

1away

4690eafd4de3df36a8c11f1105d5dac340351d81

4690eafd4de3df36a8c11f1105d5dac340351d81

Save it for future use, then re-load it. Does not show, defaults to “away”.

Here is the exposed status information from the presence plugin on 2.6.3 build 1521.

Away

away

8a86e66a695f9ba95d479ad70f63e1bfaabb60af

8a86e66a695f9ba95d479ad70f63e1bfaabb60af

Here is hte exposed status information from the presence plugin on 2.6.3 build unknown (earlier version, pre-INVISIBLE state).

Back at 8AM

1

away

8a86e66a695f9ba95d479ad70f63e1bfaabb60af

8a86e66a695f9ba95d479ad70f63e1bfaabb60af

Hmm, I see this is already reported.

http://issues.igniterealtime.org/browse/SPARK-1535

This also affects the AUTO_AWAY status, instead of saying their default away status it just defaults to ‘away’, so definitely a regression. Build prior to Invisible status being added works fine, so I am thinking it’s something with that.

Thanks for your report. That Invisibility presence patch looks like a huge mess. Already a second bug because of that and not that Invisibility adds much value… I have updated the ticket with this thread address and linked to the atch ticket. Hopefully Mircea will be able to fix this.

Regarding the custom status messages. There is a fix for this in 596 build http://bamboo.igniterealtime.org/browse/SPARK-INSTALL4J-596/artifact/JOB1/Instal l4j/ But i have found out that presence updates are not working if you are logged into some additional transports like Gtalk, MSN, etc. This additional issue will be investigated later, hopefully.