Spark 2.7.0 B671 - Wierd SSL Issue

So, I upgrade to Openfire 3.10.0 from 3.8.2. I couldn’t connect with Spark 2.6.3 with the default Security Settings -> Client Connection Security -> Optional. Temporarily, disabled TLS to get our users going, but I’ve pushed out Spark 2.7.0 to all the users.

Now, I’m trying to re-enable the optional security.

After I connect with 2.7.0, I see the little lock in the bottom. Everything works gravy.

Now comes the issue - if I hover the mouse over the lock, boom, Spark closes and/or crashes and there’s no log entry. The system tray icon stays phantom until you hover it - so it obviously is a crash. I check the logs and there’s no new entries.

Can anyone reproduce this hover over the lock error?

I don’t see it as a huge issue, but if you were unfortunate enough to hover the mouse over it for just to long, you’d have to re-open Spark. By the way, I enabled debugging, and everything still crashes at once, so I can’t capture any errors or event information.

Thank you all!


I tested it on a co-worker’s computer. They get a tool tip “Spark is running in secure mode”.


I’ve tried clearing out Appdata\Roaming\Spark folder, uninstalling, reinstalling. Nothing has worked it.

You should have started a discussion, not a document

Can’t reproduce this either. Btw, why optional? Set it to custom, set Old SSL as not available and TLS as required