powered by Jive Software

Spark 2.7.7 and 2.8.3 text turned to gibberish

Issue with Spark 2.7.7 and 2.8.3. A user received a message from another user and changed the text of her spark client. Verified that it is not a language change in the client itself. Uninstalled, and verified that all traces of the install were removed from the registry and the C drive, but when I reinstall 2.7.7, I see the following login screen.
image

I also tried installing 2.8.3, but got the same issue. When I try to type in any of the text fields, the text turns to this gibberish as well.

Haven’t see such issue yet. You may try removing Spark profile and starting with new. Spark profile is here
C:\Users\username\AppData\Roaming\Spark
If you need your history, copy this folder:
C:\Users\username\AppData\Roaming\Spark\user\username@servername\transcripts
And copy it back after you start with a fresh profile.

Removed the spark folder at C:\Users\username\AppData\Roaming\ location. Still did not fix the issue. I tried with both 2.7.7 and 2.8.3 installers as well and they both give me the following screen when try to install them:

image

I think something became wrong with the system itself. Maybe hardware corruption of some sort. I would try system restore if there are recent snapshots.

Agree with Wroot. This error is found only on the beta version of Spark 2.9.0 Snapshoot and is associated with updating the SMACK library to version 4.3.X. In your case, old versions of SMACK are used, which have no problems with non-English-language characters. Itself has about 300 Spark users with version 2.8.3 in Russian and English. There are also test clients from 2.7.6 and 2.6.3.

What is your language in the Spark client?

I think you are confusing this issue with translations error in 2.9.0. In this case even installer shows corrupted strings. We are not translating installer.