powered by Jive Software

Spark 2.8.0 Login Issues

Have read the announcement above the forums, but still having issues.

Running Openfire 4.0.3 and testing Spark 2.8.0 with no luck. Production is 2.7.7 and working fine.

Created a DNS A record to resolve server IP to spark.mydomain.com. Re ran initial setup and changed the Server Name to spark.mydomain.com (as shown in server properties in the admin console)

On Spark 2.8.0 client I am using spark.mydomain.com as the server, but can only connect when “Accept all certificates” is checked in advanced options. Invalid password is the error message (I’m assuming that’s a generic error)

All connections are LAN based only.

Accept all certificates is required because you are using a self signed certificate for openfire (default). you can get around this by using a certificate from a trusted signing authority (thats also in the java jre used by spark), or import your self signed root cert into the jre used by spark.

with spark 2.7 and older, spark just automatically accept all certs, which is why you probably never saw this issue in the past.

Thanks for the prompt reply speedy!

Could you give me instructions on how to do that? Since our IM network is purely internal, I don’t have any security concerns. Thanks

Actually “Accept all certificates” should be enabled by default. Maybe you have disabled it while testing. Try upgrading another machine to 2.8.0 and see.

1 Like

Hi, i try install 2.8.0 spark and all sertificate check, but if i try connect on my local domain he tell me i using wrong username and password. Then i’m going to openfire admin panel- “cilent connection setting” - “STARTTILS policy” - and check disabled. Then i join on spark, and using normaly.

On that page where you disable TLS (encryption) you can check what domain are your certificates for. You have to put the same name in Spark as a server.

You can also read the announcement above the forums for more information.

Hi wroot,

It is on by default. Everything looks good now. Thank you

hmmm, i’m not sure understand what you wanted to say. But when I install SPARK 2.8.0 on client computer, I must disable this options. Then people connected on domain. But sometimes when if log out and log in again, then see messeage wrong username and password. Then i must restart computer and again login on cmputer to working perfect. I dont understund why, but I trying search.

I think STARTTLS policy for disabled sertifikate. When i diselect or select whathever, then login perfect.