powered by Jive Software

Spark 2.8 login problem solved, but no search and muc

Thanks. This solved the issue. My server name is shown as “domain.com” while the DNS A record points to “jabber.domain.com”. How do I change the server name in OF 4.0.0 to match “jabber.domain.com”?

EDIT - While it allows me to log in, search (for users) and conference are broken and cannot be used…

I have branched out your issue into a separate thread to track easier.

There is no easy way to change Openfire’s name after it is already running. Other than rerunning the initial setup and then setting the correct name. This should keep the database intact, but i would do backups before doing that.

To rerun the setup,stop Openfire, edit /openfire/conf/openfire.xml, change last tag true into false. Run Openfire and go to Admin Console address.

I have a testing environment with server’s name “test” and i point to 10.0.2.2 IP in the Advanced settings. Search and MUc work for me with Spark 2.8.0.

You can try the testing build of 2.8.0 which have an option (in the Advanced menu on the Login screen) to Disable certificate hostname verification: http://download.igniterealtime.org/spark/dailybuilds/spark_2_8_0_886.exe

Keep in mind, that this will make your client vulnerable to certificate spoofing attack. But you might not care about it in a closed safe environment. Your issue seems a bit different from the others, but maybe this will help with your search and muc issues also.

I ended up reinstalling 4.0.3 from scratch and now all is well. I can search and see the conference rooms. Still having issues with file transfers but this is another issue.