powered by Jive Software

Spark 2.9.0 'Use Spark version as resource' is invalid

First install, ‘Use Spark version as resource’ is invalid. Change to ‘Use hostname as resource’, then change back, will be OK. Why?

I cannot reproduce the problem that you have. When I remove my profile (by deleting the .Spark directory in my home folder), start Spark, change the configuration settings to “Use Spark version as resource” as shown below, I can log in without problems.

After I logged in, Openfire sees me using the resource as expected:

Can you please provide more details? How do you reproduce this problem?

1 Like

image
Thanks for your reply.

image

I believe this is related to Client Control plugin. User is maybe using old version of Openfire/plugin, in which case plugin is not sending values for newly added settings that Spark expects and then settings get disabled/switched. This is an annoyance with how default settings/Client Control is designed. It always defaults to false, which brakes things when users try to use new version of Spark with older plugin.

Also in this case there is another issue with how i have implemented two new settings in 2.1.5 version of the plugin. I have set both Use hostname as resource and Use version as resource to disabled by default in Client Control. Although the same effect happens if you set both as enabled. Spark always defaults to Use hostname as resource if both are true or both false. These two settings are also interconnected in Spark itself, so i couldn’t figure out how to have both of them in Client Control. Maybe this can be improved in future versions (both Spark and plugin).

For now to have a version as resource you need to use the latest version of plugin and enable the Use version as resource in that plugin. It can take a few log outs for Spark to use that setting and then Openfire shows a version on the Sessions page.