powered by Jive Software

Spark and JRE Support(1.5 vs 1.6)

I’ve noticed that the Spark Online MSI installers, starting with 2.5.7, require the JRE 1.6 to be installed before the app will run. They will not even attempt to use a 1.5 JRE. Installation is completely successfull, but program launch fails without the 1.6 JRE installed.

The Online EXE installers have no problem with the 1.5 JRE, so my question is why the inconsistency? I can’t find any documentation for Spark that indicates that a specific version of the JRE is required. In fact, I can’t seem to find a “System Requirements” doc anywhere.

M@

Hi,

I’m not sure why the MSI requires Java 1.6. I’ll do some checking around here and let you know what I find out.

thanks,

Scott

Well, I can -see- where the change was made that updated to 1.6. Why is it required? good question. =/ If it still works with 1.5 for the exe build, I don’t really see why we’re requiring it for the MSI build. What are y’all’s thoughts? Do you think we should standardize on requiring 1.6 or go back to allowing 1.5?

Daniel

Let’s make it 1.7

I vote for 1.6. It’s not new anymore and should be common. Most of the users will complain, because they will have to upgrade they old 1.5 installation. Java is making people lazy I mean it’s hard for admins to upgrade whole company to a newer version. So i think online installers are not very useful. With offline installer you dont even have to know what java version you should have, or what is java at all.

Unless there is a programmatical need to require 1.6, I see no reason why you can’t allow 1.5 users to still use the program. Java is supposed to be a portable programming language, the spirit was to write programs that “just work” no matter what computer you were using them on. If start inventing artificial, and completely unnecessary, limitations to your program then you might as well have written in .NET.

In our case, we have an internal software package that runs on the 1.5 platform and has issues with the way that the 1.6 platform interprets the code, so we can’t install the 1.6 plugin on the pcs in our environment. It would be a real shame, if after we just implemented(on Tuesday!) Spark and Openfire in our organization, if Jive pushed out a change this drastic. We would be stuck at the current versioning and feature set. Not fun.

M@

Note that it’s not a requirement. 1.5 is allowed. The MSI installer alone, for some reason, is requiring 1.6. The .exe installer is not. There are tools to build your own MSI installers from the .exe. I don’t really know why the MSI installer was set for 1.6. I can see it being set to be distributed with 1.6, but the min version is a tad odd. Either way, no need to panic, it was a simple question. Sounds like there’s a good case to keep support for 1.5. ;D

Maenxe wrote:

In our case, we have an internal software package that runs on the 1.5 platform and has issues with the way that the 1.6 platform interprets the code

Firstly, i’m in no way want to sound rude. Just a bit offtopic.

This was always strange to me, that people/companies are getting stuck with old programs, and then requirements for old platforms appear. Some are still using NT, 1.4 java, DOS and so on. And they ask not to abandon them. But they have put themselves in such position. Why should developers maintain old requirements, or make it working with old and new platforms? It’s a users call to make a desicion, to upgrade their internal software, buy a new etc. Now 1.5 is ok, but let’s say after few months it would be abandoned. What whould you do? It could happen not just with Spark. You should be preparing for such problems now and think about changes.

Java’s independence of a platform sound more like a myth to me nowadays. Unless it would stay in 1.0 version forever. But it’s constantly evolving and progressing. It’s not possible to stay platform independent in all areas.

Speaking about this topic’s case. As i mentioned, you can use offline MSI installer. It wount harm your current 1.5 java installation. And Spark will use its internal 1.6 JRE. Or as Daniel suggested, you can create your own MSI with online EXE setup. As i understand Daniel will fix java requirement in offline MSI installer in upcoming release. Or not?

wr00t wrote:

Firstly, i’m in no way want to sound rude. Just a bit offtopic

Don’t worry, no offense taken.

I didn’t mean to sound inflammatory, I was simply stating an opinion, and the circumstances that cause me to favor that opinion. However, regardless of my circumstances, I would still recommend this approach: “Unless programmatically necessary, I see no need to require the newer version.”

Unless there is a new feature that is only available on thru the new platform, I would not recommend putting a min ver requirement. If the product works fine(as it does) on the older version then allow it. I worked in Technical Support for 6 years at a company that used their Tech Support department for QA. This allowed the people who interact with the customers all day, every day to have a direct influence on the feature set, bug control, workflow and installation requirements. I’ve seen first hand the companies that were running Win98 well into the new millenium, as well as the customers who have every iteration of the JRE from 1.3 thru 1.6 and wonder why things don’t work(I have the latest version!). Just remember that at one point WindowsME was the “Latest and Greatest!”, we all laugh now, but there were plenty who jumped on that bandwagon and regretted it.

I don’t want to dog the 1.6 platform, that was not my point, I honestly have nothing against it. However, I don’t see the need to force people’s hand unless there is a need. At this point, for Spark, I don’t think it’s there. If Jive decides, at a future date, that for the sake of Spark and the user community that they can no longer support installations utilizing the 1.5 platform then so be it, put it in the documentation. From what I’ve read, it seems that there is a possibility that they might be moving to Adobe Air, so this may all be a moot point for long term discussion.

In closing, I would like to make one final comment in response to one of wr00t’s statements:

It’s a users call to make a desicion, to upgrade their internal software, buy a new etc

In the corporate space, which I believe is a vast majority of the spark/openfire community, it is not the user’s decision. That decision lies with the Sys Admins. If we let user’s decide, we would never have implenented spark, we would have stuck with RealPopup(freeware WinPopup replacement) because it was “familiar”, or with Yahoo!(All my friends are on it!).

M@

My bad english I meant end users, those who make a company wide decisions. Not exactly sysadmins’ duty (maybe in some cases). As a bit of sysadmin myself i agree that most of the users dont want to change anything, but some of them can surprise you

The 2.5.8 online exe installer wants 1.5 or 1.6 and won’t even work with 1.7 , please allow it to work on 1.7.